summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2019-06-10 20:11:48 +0100
committerCaolán McNamara <caolanm@redhat.com>2019-06-11 11:40:11 +0200
commit5f59aad388c383e87e95c487bd415a1df8ebf145 (patch)
tree8e6073e90e64f21f3b57b5a19e394d2ebd55291c /configure.ac
parentacb803b730f2c6bd82e39beab58949ec14f85eb0 (diff)
Related: rhbz#1718063 look for pkg-config python-version-embed
Change-Id: I7048171501e32d29f9d5a58f0d5fc0b96b318a4e Reviewed-on: https://gerrit.libreoffice.org/73777 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com> Tested-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e14d3b4f4d45..fa58f9ff3591 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8462,6 +8462,9 @@ if test $enable_python = system; then
if test -z "$PKG_CONFIG"; then
PYTHON_CFLAGS="-I$python_include"
PYTHON_LIBS="-L$python_libdir -lpython$python_version $python_libs"
+ elif $PKG_CONFIG --exists python-$python_version-embed; then
+ PYTHON_CFLAGS="`$PKG_CONFIG --cflags python-$python_version-embed`"
+ PYTHON_LIBS="`$PKG_CONFIG --libs python-$python_version-embed` $python_libs"
elif $PKG_CONFIG --exists python-$python_version; then
PYTHON_CFLAGS="`$PKG_CONFIG --cflags python-$python_version`"
PYTHON_LIBS="`$PKG_CONFIG --libs python-$python_version` $python_libs"