summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2020-07-16 18:17:56 +0200
committerMiklos Vajna <vmiklos@collabora.com>2020-07-23 10:51:30 +0200
commit5fdf2009d21fa220dfee70ea755bd698c16257a7 (patch)
treea0facfa2ce98515cb48402e263eac31a34e11567 /configure.ac
parentdfc28be2487c13be36a90efd778b8d8f179c589d (diff)
tdf#134522 remove --with-build-version ./configure flag
Noop. Use --with-extra-buildid Change-Id: I110514f6f58c1cd2ca635234a20cf560e6e3d6e6 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/98923 Tested-by: Jenkins Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 3 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index be09b10a74a0..e89c23732c40 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2291,13 +2291,6 @@ AC_ARG_WITH(idlc-cpp,
[Specify the C Preprocessor to use for idlc. Default is ucpp.]),
,)
-AC_ARG_WITH(build-version,
- AS_HELP_STRING([--with-build-version="Built by Jim"],
- [Allows the builder to add a custom version tag that will appear in the
- Help/About box for QA purposes.]),
-with_build_version=$withval,
-)
-
AC_ARG_WITH(parallelism,
AS_HELP_STRING([--with-parallelism],
[Number of jobs to run simultaneously during build. Parallel builds can
@@ -7435,20 +7428,6 @@ AC_SUBST(LD_PLUGIN)
AC_CHECK_FUNCS(posix_fallocate, HAVE_POSIX_FALLOCATE=YES, [HAVE_POSIX_FALLOCATE=NO])
AC_SUBST(HAVE_POSIX_FALLOCATE)
-dnl ===================================================================
-dnl Custom build version
-dnl ===================================================================
-
-AC_MSG_CHECKING([whether to add custom build version])
-if test "$with_build_version" != ""; then
- BUILD_VER_STRING=$with_build_version
- AC_MSG_RESULT([yes, $BUILD_VER_STRING])
-else
- BUILD_VER_STRING=
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(BUILD_VER_STRING)
-
JITC_PROCESSOR_TYPE=""
if test "$_os" = "Linux" -a "$host_cpu" = "powerpc"; then
# IBMs JDK needs this...
@@ -12959,6 +12938,9 @@ AC_SUBST(PROGRESSTEXTCOLOR)
AC_SUBST(PROGRESSTEXTBASELINE)
+dnl ===================================================================
+dnl Custom build version
+dnl ===================================================================
AC_MSG_CHECKING([for extra build ID])
if test -n "$with_extra_buildid" -a "$with_extra_buildid" != "yes" ; then
EXTRA_BUILDID="$with_extra_buildid"