summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2019-07-03 11:40:58 +0200
committerLuboš Luňák <l.lunak@collabora.com>2019-07-06 10:08:51 +0200
commit68cd8a97510ccfccb98516539ddb4affc94d46fa (patch)
tree484eb8b3f120af1c8bf47eb4c5e982a061a30db4 /configure.ac
parent48741ec47852d78000f71dc9f2b3e172ba94a894 (diff)
increase parallelism with --enable-icecream from 10 to 40
My 5-year-old desktop can build 8 jobs on its own, so 10 is a rather pointless default nowadays. Icecream will spawn only as many jobs as the cluster can handle, so this should work fine even for small machines/clusters. Change-Id: Iccdf3adf51f55428e89e042d83979a1e1327659e Reviewed-on: https://gerrit.libreoffice.org/75029 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2f1f242e76fb..ba079753729f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2217,7 +2217,7 @@ AC_ARG_WITH(parallelism,
[Number of jobs to run simultaneously during build. Parallel builds can
save a lot of time on multi-cpu machines. Defaults to the number of
CPUs on the machine, unless you configure --enable-icecream - then to
- 10.]),
+ 40.]),
,)
AC_ARG_WITH(all-tarballs,
@@ -12409,7 +12409,7 @@ if test -n "$with_parallelism" -a "$with_parallelism" != "yes"; then
fi
else
if test "$enable_icecream" = "yes"; then
- PARALLELISM="10"
+ PARALLELISM="40"
else
case `uname -s` in