summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoel Grandin <noel.grandin@collabora.co.uk>2019-08-12 10:26:43 +0200
committerNoel Grandin <noel.grandin@collabora.co.uk>2019-08-12 15:27:09 +0200
commit485274ec00cea328cd426c8d952e70eb0892746d (patch)
tree0f901c271392f27b6c537d40ef3f3554af55df3c /configure.ac
parent4721cbb1bb118d33ac9fcf93dda8c083b364003d (diff)
improve error message for gtk configure
Change-Id: I0b46302bbb15777992d59597109fe9ebd76a525e Reviewed-on: https://gerrit.libreoffice.org/77346 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3dcae0fa9984..1aeaa6184eb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10606,11 +10606,12 @@ GTK_LIBS=""
if test "$test_gtk" = "yes"; then
if test "$ENABLE_GTK" = "TRUE"; then
- PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.18.0 gdk-pixbuf-2.0 >= 2.2 ,,AC_MSG_ERROR([requirements to build the gtk-plugin not met. Use --disable-gtk or install the missing packages]))
+ PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.18.0 ,,AC_MSG_ERROR([requirements to build the gtk-plugin not met (gtk+-2.0 >= 2.18.0). Use --disable-gtk or install the missing packages]))
+ PKG_CHECK_MODULES(GTK, gdk-pixbuf-2.0 >= 2.2 ,,AC_MSG_ERROR([requirements to build the gtk-plugin not met (gdk-pixbuf-2.0 >= 2.2). Use --disable-gtk or install the missing packages]))
GTK_CFLAGS=$(printf '%s' "$GTK_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${GTK_LIBS}"
GTK_LIBS="${filteredlibs}"
- PKG_CHECK_MODULES(GTHREAD, gthread-2.0,,AC_MSG_ERROR([requirements to build the gtk-plugin not met. Use --disable-gtk or install the missing packages]))
+ PKG_CHECK_MODULES(GTHREAD, gthread-2.0,,AC_MSG_ERROR([requirements to build the gtk-plugin not met (gthread-2.0). Use --disable-gtk or install the missing packages]))
BUILD_TYPE="$BUILD_TYPE GTK"
GTHREAD_CFLAGS=$(printf '%s' "$GTK_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
FilterLibs "${GTHREAD_LIBS}"