summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2015-11-30 21:19:52 +0100
committerMichael Stahl <mstahl@redhat.com>2015-12-01 10:51:46 +0100
commit037584cfe5e58bf6807fb0188d245042baa8c1c0 (patch)
tree9945ab0fab6ab8241f91d6e22e4dae04de397639 /configure.ac
parent3fc4374d66f2bb963e622c591de7482789681fc3 (diff)
configure: check for dlsym(), not dlopen()
On Fedora 23, the check for dlopen happens to succeed with gcc -m32 -fsanitize=address, and then linking executables fails due to not finding dlsym. Checking for dlsym results in the proper -ldl. Change-Id: I02108c2c053e07b33848af068937f29967e7dc6a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index eb569d10afe7..859372216bef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -904,9 +904,9 @@ AC_SUBST(PTHREAD_LIBS)
if test $_os != "WINNT"; then
save_LIBS="$LIBS"
- AC_SEARCH_LIBS([dlopen], [dl],
- [case "$ac_cv_search_dlopen" in -l*) DLOPEN_LIBS="$ac_cv_search_dlopen";; esac],
- [AC_MSG_ERROR([dlopen not found in either libc nor libdl])])
+ AC_SEARCH_LIBS([dlsym], [dl],
+ [case "$ac_cv_search_dlsym" in -l*) DLOPEN_LIBS="$ac_cv_search_dlsym";; esac],
+ [AC_MSG_ERROR([dlsym not found in either libc nor libdl])])
LIBS="$save_LIBS"
fi
AC_SUBST(DLOPEN_LIBS)