summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2015-08-07 19:29:04 +0200
committerMichael Stahl <mstahl@redhat.com>2015-08-07 19:31:30 +0200
commit2d76030d985b53779e2363b559f441613f5c677c (patch)
treef910765d91f9729bb73c122aedf20d969c4386d6 /configure.ac
parentcf27d96fa3bffe603941f3e11e871b3202a3ba96 (diff)
configure: *another* --enable-selective-debuginfo pitfall
Change-Id: I5f04b71d01c163edde55f01becfe2e460f4bc9c7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 274ff7f3f7f4..0d45455ff8b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3927,6 +3927,10 @@ if test -n "$ENABLE_DEBUG"; then
ENABLE_DEBUGINFO_FOR=all
AC_MSG_RESULT([no, for all])
fi
+else
+ if test -n "$enable_selective_debuginfo"; then
+ AC_MSG_ERROR([--enable-selective-debuginfo must be used together with either --enable-debug or --enable-dbgutil])
+ fi
fi
AC_SUBST(ENABLE_DEBUGINFO_FOR)