summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2013-06-18 13:58:49 +0200
committerStephan Bergmann <sbergman@redhat.com>2013-06-18 13:58:49 +0200
commit08337321e655a3b4991c895de98d96858e60d863 (patch)
tree10115b317e6277414e3777530d9c652483dd31f4 /configure.ac
parent4a0247603e94412c1a77af8e8c7bd17f729b9eba (diff)
Let WINDOWS_SDK_WILANGID override the location of WiLangId.vbs
...see new TODO comment in configure.ac Change-Id: Id3ffd45357a3f539f3d3f068528019334d929654
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4efc4f947bff..0596eb79ca81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9066,9 +9066,21 @@ the Windows SDK are installed.])
SOLARINC="$SOLARINC -I$WINDOWS_SDK_HOME/include/um -I$WINDOWS_SDK_HOME/include/shared"
fi
fi
+
+ dnl TODO: solenv/bin/modules/installer/windows/msiglobal.pm wants to use a
+ dnl WiLangId.vbs that is included only in some SDKs (e.g., included in v7.1
+ dnl but not in v8.0), so allow this to be overriden with a
+ dnl WINDOWS_SDK_WILANGID for now; a full-blown --with-windows-sdk-wilangid
+ dnl and configuration error if no WiLangId.vbs is found would arguably be
+ dnl better, but I do not know under which conditions exactly it is needed by
+ dnl msiglobal.pm:
+ if test -z "$WINDOWS_SDK_WILANGID" -a -n "$WINDOWS_SDK_HOME"; then
+ WINDOWS_SDK_WILANGID=$WINDOWS_SDK_HOME/Samples/sysmgmt/msi/scripts/WiLangId.vbs
+ fi
fi
AC_SUBST(WINDOWS_SDK_HOME)
AC_SUBST(WINDOWS_SDK_VERSION)
+AC_SUBST(WINDOWS_SDK_WILANGID)
dnl =========================================
dnl Check for uuidgen