summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2014-03-19 11:24:57 +0100
committerStephan Bergmann <sbergman@redhat.com>2014-03-19 11:26:37 +0100
commit4999a73991e6995e8d307c7653bfbf29a15573ec (patch)
treeaf07abf2647150c9cb963b1c7cff24b9572e1fb1 /configure.ac
parent233610f1245685a3f27cf9633c93568bd1d300da (diff)
--enable-python=fully-internal to force PYTHON_FOR_BUILD=
(for testing purposes, mainly) Change-Id: I50d3c92b9ac0cc9dda55b7340f657acb74f675f6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 10 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index f372fe0318dd..89a816687984 100644
--- a/configure.ac
+++ b/configure.ac
@@ -950,10 +950,11 @@ AC_ARG_ENABLE(crashdump,
[Enable the crashdump feature.]))
AC_ARG_ENABLE(python,
- AS_HELP_STRING([--enable-python=<no/auto/system/internal>],
+ AS_HELP_STRING([--enable-python=<no/auto/system/internal/fully-internal>],
[Enables or disables Python support at run-time and build-time.
- Also specifies what Python to use. 'auto' is the
- default.]))
+ Also specifies what Python to use. 'auto' is the default.
+ 'fully-internal' even forces the internal version for uses of Python
+ during the build (for testing purposes, mainly).]))
AC_ARG_ENABLE(gtk,
AS_HELP_STRING([--disable-gtk],
@@ -7819,7 +7820,7 @@ AC_SUBST(XMLLINT)
# Optionally user can pass an option to configure, i. e.
# ./configure PYTHON=/usr/bin/python
# =====================================================================
-if test "$build_os" != "cygwin"; then
+if test "$build_os" != "cygwin" -a "$enable_python" != fully-internal; then
# This allows a lack of system python with no error, we use internal one in that case.
AM_PATH_PYTHON([2.5],, [:])
# Clean PYTHON_VERSION checked below if cross-compiling
@@ -7854,7 +7855,7 @@ no|disable)
dnl (When cross-compiling to Windows from Linux using the mingw32-cross
dnl compiler from OBS, use mingw32-python from OBS, and ditto for other
dnl MinGW cross-compilation setups.)
- AC_MSG_RESULT([internal])
+ AC_MSG_RESULT([fully internal])
enable_python=internal
elif test "$cross_compiling" = yes; then
AC_MSG_RESULT([system])
@@ -7876,6 +7877,10 @@ no|disable)
internal)
AC_MSG_RESULT([internal])
;;
+fully-internal)
+ AC_MSG_RESULT([fully internal])
+ enable_python=internal
+ ;;
system)
AC_MSG_RESULT([system])
;;