summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2013-01-20 23:21:56 -0600
committerTor Lillqvist <tml@iki.fi>2013-01-21 08:32:45 +0000
commit62bc5c29ff518f849d5a29747355382f75d99364 (patch)
treec73adf4edad1d651e65a252eb45ad209b4b7af30 /configure.ac
parent75e32e150133511d8f098a253a56426ed0302cec (diff)
disable odk if not explicitly requested and doxygen not in PATH
if odk is not explicitly requested by --enable-odk and --with-doxygen is "yes" , i.e not a specific location and doxygen could not be found in the PATH then enable_odk is set to "no" as a default value rather than an implicit 'yes' Change-Id: I4f04ecc8dbe959001f6dfdccf0c97b61f79faff6 Reviewed-on: https://gerrit.libreoffice.org/1789 Reviewed-by: Tor Lillqvist <tml@iki.fi> Tested-by: Tor Lillqvist <tml@iki.fi>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac49
1 files changed, 27 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 23ebf23562ba..c005756937f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6944,6 +6944,33 @@ AC_SUBST(GPERF)
dnl ===================================================================
dnl Check for building ODK
dnl ===================================================================
+if test "$enable_odk" = no; then
+ unset DOXYGEN
+else
+ if test "$with_doxygen" = no; then
+ AC_MSG_CHECKING([for doxygen])
+ unset DOXYGEN
+ AC_MSG_RESULT([no])
+ else
+ if test "$with_doxygen" = yes; then
+ AC_PATH_PROG([DOXYGEN], [doxygen])
+ if test -z "$DOXYGEN"; then
+ AC_MSG_RESULT([no])
+ if test "$enable_odk" = "" ; then
+ enable_odk="no"
+ else
+ AC_MSG_ERROR([doxygen not found in \$PATH; specify its pathname via --with-doxygen=..., or disable its use via --without-doxygen])
+ fi
+ fi
+ else
+ AC_MSG_CHECKING([for doxygen])
+ DOXYGEN=$with_doxygen
+ AC_MSG_RESULT([$DOXYGEN])
+ fi
+ fi
+fi
+AC_SUBST([DOXYGEN])
+
AC_MSG_CHECKING([whether to build the ODK])
if test "$enable_odk" = "" -o "$enable_odk" != "no"; then
AC_MSG_RESULT([yes])
@@ -11655,28 +11682,6 @@ location (/usr/share/java), specify its pathname via
fi
AC_SUBST(OOO_JUNIT_JAR)
-if test "$enable_odk" = no; then
- unset DOXYGEN
-else
- if test "$with_doxygen" = no; then
- AC_MSG_CHECKING([for doxygen])
- unset DOXYGEN
- AC_MSG_RESULT([no])
- else
- if test "$with_doxygen" = yes; then
- AC_PATH_PROG([DOXYGEN], [doxygen])
- if test -z "$DOXYGEN"; then
- AC_MSG_RESULT([no])
- AC_MSG_ERROR([doxygen not found in \$PATH; specify its pathname via --with-doxygen=..., or disable its use via --without-doxygen])
- fi
- else
- AC_MSG_CHECKING([for doxygen])
- DOXYGEN=$with_doxygen
- AC_MSG_RESULT([$DOXYGEN])
- fi
- fi
-fi
-AC_SUBST([DOXYGEN])
AC_SUBST(SCPDEFS)