summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2016-09-05 01:53:31 +0200
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2017-05-19 03:43:22 +0200
commit641bd985386c4accfcc99afb769db2385462ffe8 (patch)
tree6bd56250e0231cf98eaaf17831d31bc255aa3630 /configure.ac
parent6c3fa47fc9a22bbe78e2aa8a016af922003580f5 (diff)
create complete and correct build_config files for the updater
Change-Id: I4f6b7aecc24d42d6b248cb8d959aeab59af963c2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 63334a7c4aa7..4c1e4f47b2c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1398,6 +1398,12 @@ AC_ARG_WITH(update-certificate-path,
[Defines the path to the nss certificate store used for the updater
This makes only sense if the onlineupdate is used and the mar files should be uploaded.]))
+AC_ARG_WITH(update-base-url,
+ AS_HELP_STRING([--with-update-base-url=http://dev-builds.libreoffice.org/update/$(channel)/$(buildid)],
+ [Defines the base url for the mar file url. THe following variables are going to be replaced
+ with the corresponding content: channel, buildid, version, platform, productname.
+ This makes only sense if the onlineupdate is used and the mar files should be uploaded.]))
+
libo_FUZZ_ARG_ENABLE(extension-update,
AS_HELP_STRING([--disable-extension-update],
[Disable possibility to update installed extensions.]),
@@ -11321,6 +11327,7 @@ ENABLE_ONLINE_UPDATE_MAR=
UPDATE_CHANNEL=
UPDATE_CERTIFICATE_NAME=
UPDATE_CERTIFICATE_PATH=
+UPDATE_BASE_URL=
if test "$enable_online_update" = ""; then
if test "$_os" = "WINNT" -o "$_os" = "Darwin"; then
AC_MSG_RESULT([yes])
@@ -11336,6 +11343,7 @@ else
UPDATE_CHANNEL="$with_update_channel"
UPDATE_CERTIFICATE_NAME="$with_update_certificate_name"
UPDATE_CERTIFICATE_PATH="$with_update_certificate_path"
+ UPDATE_BASE_URL="$with_update_base_url"
elif test "$enable_online_update" = "yes"; then
AC_MSG_RESULT([yes])
ENABLE_ONLINE_UPDATE="TRUE"
@@ -11348,6 +11356,7 @@ AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
AC_SUBST(UPDATE_CHANNEL)
AC_SUBST(UPDATE_CERTIFICATE_NAME)
AC_SUBST(UPDATE_CERTIFICATE_PATH)
+AC_SUBST(UPDATE_BASE_URL)
dnl ===================================================================
dnl Test whether we need bzip2