summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2014-01-26 22:05:38 -0600
committerNorbert Thiebaud <nthiebaud@gmail.com>2014-01-26 22:05:58 -0600
commit0c9e4d9b223a0593686bee800484de3c23095d4f (patch)
treeea211eccbc0abf9d6534e4d14e2211e866e9bb9a /configure.ac
parent121d5d545b256333543b4679ef64313fac4ad109 (diff)
macosx: add --enable-macosx-retina
this tell the info.plist that the application is 'high resolution enabled' Change-Id: I8e43e20f78c822d1cebab873f340143fe2dee4ea
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb5130856577..4707ab22359d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1211,6 +1211,12 @@ AC_ARG_ENABLE(silent-msi,
[Enable MSI with LIMITUI=1 (silent install).]),
,)
+AC_ARG_ENABLE(macosx-retina,
+ AS_HELP_STRING([--enable-macosx-retina],
+ [Declare the application as High Resolution Capable. (retina display)
+ ]),
+,)
+
AC_ARG_ENABLE(macosx-code-signing,
AS_HELP_STRING([--enable-macosx-code-signing<=identity>],
[Sign executables, dylibs, frameworks and the app bundle. If you
@@ -2916,6 +2922,14 @@ if test $_os = Darwin; then
MACOSX_BUNDLE_IDENTIFIER=$with_macosx_bundle_identifier
AC_MSG_RESULT([$MACOSX_BUNDLE_IDENTIFIER])
+
+ AC_MSG_CHECKING([build with mac retina support])
+ if test "$enable_macosx_retina" = yes ; then
+ MACOSX_HIGH_RESOLUTION_VALUE=true
+ else
+ MACOSX_HIGH_RESOLUTION_VALUE=false
+ fi
+ AC_MSG_RESULT([$MACOSX_HIGH_RESOLUTION_VALUE])
fi
AC_SUBST(MACOSX_SDK_PATH)
AC_SUBST(MACOSX_SDK_VERSION)
@@ -2927,6 +2941,7 @@ AC_SUBST(LIBTOOL) # Note that the OS X libtool command is unrelated to GNU libto
AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
+AC_SUBST(MACOSX_HIGH_RESOLUTION_VALUE)
dnl ===================================================================
dnl Check iOS SDK and compiler