summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-02-11 19:11:47 +0100
committerMichael Stahl <mstahl@redhat.com>2014-02-12 09:53:10 +0100
commit5378deaea3a499003be14f97bd1a9fb3e729a698 (patch)
tree8eb57fa5e71c962cb254f0f30cde294dfc06ef0c /configure.ac
parentff69e725c218a36d64153b36eb1fecd2b6057803 (diff)
normalize values of SYSTEM_ODBC_HEADERS, SYSTEM_OPENLDAP
Change-Id: I913c38878a110625747fbf32ad9c43ad0dab30d3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8a4c2439a6fb..f660a9b1d083 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8839,7 +8839,7 @@ dnl ===================================================================
AC_MSG_CHECKING([which odbc headers to use])
if test "$with_system_odbc" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_ODBC_HEADERS=YES
+ SYSTEM_ODBC_HEADERS=TRUE
AC_CHECK_HEADER(sqlext.h, [],
[AC_MSG_ERROR(odbc not found. install odbc)], [])
@@ -8847,7 +8847,7 @@ elif test "$enable_database_connectivity" != yes; then
AC_MSG_RESULT([none])
else
AC_MSG_RESULT([internal])
- SYSTEM_ODBC_HEADERS=NO
+ SYSTEM_ODBC_HEADERS=
fi
AC_SUBST(SYSTEM_ODBC_HEADERS)
@@ -8860,13 +8860,13 @@ if test "$_os" != "WINNT" -a "$_os" != "iOS" -a "$_os" != "Android"; then
AC_MSG_CHECKING([which openldap library to use])
if test "$with_system_openldap" = "yes"; then
AC_MSG_RESULT([external])
- SYSTEM_OPENLDAP=YES
+ SYSTEM_OPENLDAP=TRUE
AC_CHECK_HEADERS(ldap.h, [], [AC_MSG_ERROR(ldap.h not found. install openldap libs)], [])
AC_CHECK_LIB([ldap], [ldap_simple_bind_s], [:], [AC_MSG_ERROR(openldap lib not found or functional)], [])
AC_CHECK_LIB([ldap], [ldap_set_option], [:], [AC_MSG_ERROR(openldap lib not found or functional)], [])
else
AC_MSG_RESULT([internal])
- SYSTEM_OPENLDAP=NO
+ SYSTEM_OPENLDAP=
BUILD_TYPE="$BUILD_TYPE OPENLDAP"
fi
fi