summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorbrainbreaker <gautamprajapati06@gmail.com>2017-07-10 23:41:21 +0530
committerMiklos Vajna <vmiklos@collabora.co.uk>2017-07-19 10:46:18 +0200
commitc57631351c2acf9fd47050ec6e73a09dcc7d95bd (patch)
treeca04cc88ae47b8eabcb4c2b0392a68a8a0fc2cfa /configure.ac
parent17a8aadf764061b5be766e8edff3f01a12fe0993 (diff)
android:Update configure.ac to support NDK 15.1.x
Change-Id: I07ec4df7cb5aaf4b491fac1202d2607af9f56968 Reviewed-on: https://gerrit.libreoffice.org/39780 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6344d6ebf56d..119cdea487ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -381,16 +381,16 @@ if test -n "$with_android_ndk"; then
fi
case $ANDROID_NDK_VERSION in
r9*|r10*)
- AC_MSG_ERROR([Bulding for Android is only supported with NDK versions above 15.0.*])
+ AC_MSG_ERROR([Bulding for Android is only supported with NDK versions above 15.x*])
;;
11.1.*|12.1.*|13.1.*|14.1.*)
- AC_MSG_ERROR([Bulding for Android is only supported with NDK versions above 15.0.*])
+ AC_MSG_ERROR([Bulding for Android is only supported with NDK versions above 15.x.*])
;;
- 15.0.*)
+ 15.0.*|15.1.*)
;;
*)
- AC_MSG_WARN([Untested android NDK version $ANDROID_NDK_VERSION, only version 15.0.* have been used successfully. Proceed at your own risk.])
- add_warning "Untested android NDK version $ANDROID_NDK_VERSION, only version 15.0.* have been used successfully. Proceed at your own risk."
+ AC_MSG_WARN([Untested android NDK version $ANDROID_NDK_VERSION, only version 15.0.* and 15.1.* have been used successfully. Proceed at your own risk.])
+ add_warning "Untested android NDK version $ANDROID_NDK_VERSION, only version 15.0.* and 15.1.* have been used successfully. Proceed at your own risk."
;;
esac