summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-06-16 10:57:12 +0200
committerStephan Bergmann <sbergman@redhat.com>2017-06-16 15:22:32 +0200
commitc127c19de62201b49b6647ef3ee8b08ae49da852 (patch)
tree30a747e4bd593edb4878a0c97c9983c0caab2654 /configure.ac
parent9c0cd667da908ec1dde193c83d7d69a31b43e934 (diff)
Remove HAVE_CXX11_REF_QUALIFIER, always true now
...after 579497164f6bddfeb14bb6b0f4b9cd3322af1803 "Bump GCC baseline to 4.8.1" Make this a fatal configuration error for now. The check should be removed completely after LO 6.0 branch-off. Change-Id: I70cf65d6b0eb7158008f28449794c66c1b775916 Reviewed-on: https://gerrit.libreoffice.org/38869 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9ebf25de6efd..f0c09476b7b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6228,8 +6228,8 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
AC_LANG_POP([C++])
CXXFLAGS=$save_CXXFLAGS
AC_MSG_RESULT([$cxx11_ref_qualifier])
-if test "$cxx11_ref_qualifier" = yes; then
- AC_DEFINE([HAVE_CXX11_REF_QUALIFIER])
+if test "$cxx11_ref_qualifier" = no; then
+ AC_MSG_ERROR([Your $CXX does not support C++11 ref-qualifiers. This is no longer supported.])
fi
dnl _Pragma support (may require C++11)