summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2022-10-28 09:07:29 +0100
committerCaolán McNamara <caolanm@redhat.com>2022-10-28 15:52:10 +0200
commit2c0997900d35e54466d479c9c5437d447ba9b165 (patch)
tree46883d2c0cc31a57c0091c8ce60601239f1526fd /configure.ac
parent2fce155c8939c83d80cacc4ead8110ff75ce1b4c (diff)
ofz: build-failure use with-tls result for curl
otherwise with (default due to --disable-dynamic-loading) --disable-nss we get: configure: error: select TLS backend(s) or disable TLS with --without-ssl. Select from these: --with-amissl --with-bearssl --with-gnutls --with-mbedtls --with-nss --with-openssl (also works for BoringSSL and libressl) --with-rustls --with-schannel --with-secure-transport --with-wolfssl alternative we could --without-ssl entirely without nss Change-Id: Iea25b918c135664dffacfb74089d7c7c0818695e Reviewed-on: https://gerrit.libreoffice.org/c/core/+/141956 Tested-by: Jenkins Reviewed-by: Caolán McNamara <caolanm@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index df1d03a14488..8446105fceac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2163,12 +2163,11 @@ AC_ARG_WITH(package-format,
AC_ARG_WITH(tls,
AS_HELP_STRING([--with-tls],
[Decides which TLS/SSL and cryptographic implementations to use for
- LibreOffice's code. Notice that this doesn't apply for depending
- libraries like "curl", for example. Default is to use NSS
- although OpenSSL is also possible. Notice that selecting NSS restricts
- the usage of OpenSSL in LO's code but selecting OpenSSL doesn't
- restrict by now the usage of NSS in LO's code. Possible values:
- openssl, nss. Example: --with-tls="nss"]),
+ LibreOffice's code. Default is to use NSS although OpenSSL is also
+ possible. Notice that selecting NSS restricts the usage of OpenSSL
+ in LO's code but selecting OpenSSL doesn't restrict by now the
+ usage of NSS in LO's code. Possible values: openssl, nss.
+ Example: --with-tls="nss"]),
,)
AC_ARG_WITH(system-libs,