summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2022-10-18 12:51:52 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2022-10-23 12:11:29 +0200
commit3336cb1b3d12e9cd5c2f560c82129dc8ed7527da (patch)
tree08199a25c4b5c0c317881ca1359bd6538cc9f8f4 /configure.ac
parent158014e9aecbec6afb0ebf3aceb8b09e4a64b8e0 (diff)
macOS: add XCode and SDK buildversions to Info.plist
without those submitting a build for external testing via testflight is not possible because appstore thinks you were using a beta version of XCode Change-Id: I6979a9d290c3e67dd9969d6e535625760b639c25 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/141496 Tested-by: Jenkins Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 259001e70b65..a40c08e16b29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3428,7 +3428,7 @@ if test $_os = Darwin; then
fi
AC_MSG_RESULT([macOS SDK $macosx_sdk at $MACOSX_SDK_PATH])
-
+ MACOSX_SDK_BUILD_VERSION=$(xcodebuild -version -sdk "$MACOSX_SDK_PATH" ProductBuildVersion)
case $macosx_sdk in
10.13)
MACOSX_SDK_VERSION=101300
@@ -3491,6 +3491,9 @@ if test $_os = Darwin; then
AC_MSG_ERROR(["$my_xcode_ver1" is too old or unrecognized, must be at least Xcode 12.5])
fi
+ my_xcode_ver1=$(xcrun xcodebuild -version | tail -n 1)
+ MACOSX_XCODE_BUILD_VERSION=${my_xcode_ver1#Build version }
+
case "$with_macosx_version_min_required" in
10.14)
MAC_OS_X_VERSION_MIN_REQUIRED="101400"
@@ -3661,6 +3664,8 @@ AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
AC_SUBST(MACOSX_PROVISIONING_INFO)
AC_SUBST(MACOSX_PROVISIONING_PROFILE)
+AC_SUBST(MACOSX_SDK_BUILD_VERSION)
+AC_SUBST(MACOSX_XCODE_BUILD_VERSION)
dnl ===================================================================
dnl Check iOS SDK and compiler