summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2020-05-06 10:35:54 +0200
committerLuboš Luňák <l.lunak@collabora.com>2020-05-06 14:20:19 +0200
commitda2116dd2eeaedbd8d22f6f46da56ce212e2be15 (patch)
tree9d3c653682b4543d260eb45374de2047261bdd1e /configure.ac
parent65f3aea4727123a75dbd471592fe711998b5209b (diff)
always build Skia optimized, unless --enable-skia=debug
In raster mode the performance may make quite a difference, this is the drawing library (that's now the Windows default) and LO developers mostly do not need to debug Skia itself. Change-Id: I42f0407d37a2294b062a41d94566e8a4f5f4354b Reviewed-on: https://gerrit.libreoffice.org/c/core/+/93557 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1c7dff3f5d0d..40a5a2e62ed5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1076,7 +1076,7 @@ libo_FUZZ_ARG_ENABLE(pdfium,
libo_FUZZ_ARG_ENABLE(skia,
AS_HELP_STRING([--disable-skia],
- [Disable building Skia.])
+ [Disable building Skia. Use --enable-skia=debug to build without optimizations.])
)
###############################################################################
@@ -11119,7 +11119,13 @@ AC_SUBST(POPPLER_LIBS)
AC_MSG_CHECKING([whether to build Skia])
ENABLE_SKIA=
if test "$enable_skia" != "no" -a "$build_skia" = "yes"; then
- AC_MSG_RESULT([yes])
+ if test "$enable_skia" = "debug"; then
+ AC_MSG_RESULT([yes (debug)])
+ ENABLE_SKIA_DEBUG=TRUE
+ else
+ AC_MSG_RESULT([yes])
+ ENABLE_SKIA_DEBUG=
+ fi
ENABLE_SKIA=TRUE
AC_DEFINE(HAVE_FEATURE_SKIA)
BUILD_TYPE="$BUILD_TYPE SKIA"
@@ -11127,6 +11133,7 @@ else
AC_MSG_RESULT([no])
fi
AC_SUBST(ENABLE_SKIA)
+AC_SUBST(ENABLE_SKIA_DEBUG)
CLANG_CXXFLAGS_INTRINSICS_SSE2=
CLANG_CXXFLAGS_INTRINSICS_SSSE3=