summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaled@aliftype.com>2022-09-30 12:35:10 +0200
committerخالد حسني <khaled@aliftype.com>2022-09-30 16:17:22 +0200
commitfb417ee082afdd2e80a1f48aa420bb8d5cb97686 (patch)
tree384a831e01a38e825a829636b901a9be6e535083 /configure.ac
parent5948e2e9f032916e3278f904097eff6b47b869d6 (diff)
vcl: Apply variations to font metrics
Use HarfBuzz API instead of reading the raw font table directly, since HarfBuzz will apply the font variations as needed. For non-variable fonts we still also use HarfBuzz font metrics API, but in a more fine-grained way to maintain backward-compatibility. Change-Id: If6b12a11ecb63356be92ef4f0714355ae77378f2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/140799 Tested-by: Jenkins Reviewed-by: خالد حسني <khaled@aliftype.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 340e87d75b55..ab2c744fb26d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10882,7 +10882,7 @@ libo_CHECK_SYSTEM_MODULE([graphite],[GRAPHITE],[graphite2 >= 0.9.3])
HARFBUZZ_CFLAGS_internal="-I${WORKDIR}/UnpackedTarball/harfbuzz/src"
HARFBUZZ_LIBS_internal="-L${WORKDIR}/UnpackedTarball/harfbuzz/src/.libs -lharfbuzz"
-libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 2.1.0])
+libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz-icu >= 2.6.0])
if test "$COM" = "MSC"; then # override the above
GRAPHITE_LIBS="${WORKDIR}/LinkTarget/StaticLibrary/graphite.lib"