summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathias Hasselmann <mathias@openismus.com>2013-03-23 10:19:18 +0100
committerMichael Meeks <michael.meeks@suse.com>2013-03-23 10:08:16 +0000
commit7d48d67b06f9f0c144bc84155ba0f891041d109f (patch)
tree39ca145b6a6655d5c49462f7e728e13d7be56a6b /configure.ac
parent444afc083500c3a4c2d2010f4886df49e75b7773 (diff)
Use the make binary that configure found in PATH
When auto-detecting the GNU make binary from PATH store its absolute path in the GNUMAKE variable to ensure to keep using exactly the same GNU make binary even when the PATH settings change. This is needed because the gbuild system relies on the GNU make features detected and reported by the configure script. Change-Id: I05916f0ad7f2e98e4e908455ed72758ebf396863 Reviewed-on: https://gerrit.libreoffice.org/2924 Reviewed-by: Michael Meeks <michael.meeks@suse.com> Tested-by: Michael Meeks <michael.meeks@suse.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7cd27f0fb730..ebb26a862ee8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4494,7 +4494,7 @@ for a in "$MAKE" "$GNUMAKE" make gmake gnumake; do
if test -n "$a"; then
$a --version 2> /dev/null | grep GNU 2>&1 > /dev/null
if test $? -eq 0; then
- GNUMAKE=$a
+ GNUMAKE=`which $a`
break
fi
fi