summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2013-04-20 13:00:56 +0200
committerFridrich Strba <fridrich@documentfoundation.org>2013-04-23 08:00:14 +0000
commit7e389f4def1964ee38bb93b575926a089e84bae6 (patch)
tree73d2e4a7e3c17552e2ed551559e3faa3b60f12e7 /configure.ac
parent4f800d308edcad47833f1bed140d0ddcb96c420d (diff)
Add HarfBuzz support to the build system
To be used in the next commit. Change-Id: I6ee286d0c050a5ca650e7fb3692b0facccb5f0c0 Reviewed-on: https://gerrit.libreoffice.org/3517 Reviewed-by: Fridrich Strba <fridrich@documentfoundation.org> Tested-by: Fridrich Strba <fridrich@documentfoundation.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 21524877e973..6b844d6a304b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -720,6 +720,11 @@ AC_ARG_ENABLE(graphite,
[Enables the compilation of Graphite smart font rendering.])
)
+AC_ARG_ENABLE(harfbuzz,
+ AS_HELP_STRING([--enable-harfbuzz],
+ [Determines whether to use HarfBuzz text layout engine.])
+)
+
AC_ARG_ENABLE(fetch-external,
AS_HELP_STRING([--disable-fetch-external],
[Disables fetching external tarballs from web sources.])
@@ -8378,6 +8383,20 @@ fi
AC_SUBST(ENABLE_GRAPHITE)
dnl ===================================================================
+dnl HarfBuzz
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable HarfBuzz support])
+if test "$_os" != "WINNT" -a "$_os" != "Darwin" && test "$enable_harfbuzz" = "" -o "$enable_harfbuzz" != "no"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_HARFBUZZ="TRUE"
+ AC_DEFINE(ENABLE_HARFBUZZ)
+ libo_CHECK_SYSTEM_MODULE([harfbuzz],[HARFBUZZ],[harfbuzz >= 0.9.10])
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_HARFBUZZ)
+
+dnl ===================================================================
dnl Check for NPAPI interface to plug browser plugins into LibreOffice documents
dnl ===================================================================
AC_MSG_CHECKING([whether to plug browser plugins into LibreOffice documents])
@@ -11880,6 +11899,7 @@ AC_CONFIG_HEADERS([config_host/config_clang.h])
AC_CONFIG_HEADERS([config_host/config_features.h])
AC_CONFIG_HEADERS([config_host/config_global.h])
AC_CONFIG_HEADERS([config_host/config_graphite.h])
+AC_CONFIG_HEADERS([config_host/config_harfbuzz.h])
AC_CONFIG_HEADERS([config_host/config_kde4.h])
AC_CONFIG_HEADERS([config_host/config_mingw.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])