summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-04-12 02:37:46 +0300
committerTor Lillqvist <tml@iki.fi>2013-04-12 02:38:04 +0300
commit873d2149f76b2031a8bc83daba3d6fad7560588a (patch)
treef2a75fcd3d4fdbe3f5d2f6ecd9ae3d60f25afebe /configure.ac
parentebb09ee4f0b9691895d81c77666b141241683175 (diff)
No point in even considering mergelibs for Android or iOS
Change-Id: I2b587946f094cd4e83f4148d6e3359452ec36bf6
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 96ddaf761b54..cd9f0d06b684 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11633,8 +11633,15 @@ fi
# ===================================================================
AC_MSG_CHECKING([whether to create huge library])
MERGELIBS=
+
+if test $_os = iOS -o $_os = Android; then
+ # Never any point in mergelibs for these as we build just static
+ # libraries anyway...
+ enable_mergelibs=no
+fi
+
if test "$enable_mergelibs" != "no"; then
- if test $_os != Linux -a $_os != Android -a $_os != WINNT; then
+ if test $_os != Linux -a $_os != WINNT; then
add_warning "--enable-mergelibs is not tested for this platform"
fi
if test "$enable_mergelibs" = "all"; then