summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-04-19 19:31:49 +0200
committerDavid Tardon <dtardon@redhat.com>2013-04-24 05:17:25 +0000
commit9ccd994d445c797a48cb89ce2b7449adc68b1007 (patch)
tree21a0598967c57152a8b59cfcfe219ff8a6ced2a4 /configure.ac
parent6c7659b584ea7ed3652ca4eb9a2297f36310c365 (diff)
Revert "add extra inc. dir for URE headers"
Not needed anymore after moving the headers to $(SRCDIR)/include . This reverts commit ea09e0352a82dabc26c713adc1825d89ff824178. Conflicts: configure.ac Change-Id: I96c86152d3eff66ccadc9fd76131c0b57763afae Reviewed-on: https://gerrit.libreoffice.org/3500 Reviewed-by: David Tardon <dtardon@redhat.com> Tested-by: David Tardon <dtardon@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 9 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 33e67d0a0f5b..34cc0b3e46e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3388,20 +3388,11 @@ AC_SUBST(x_OBJCFLAGS)
AC_SUBST(x_OBJCXXFLAGS)
AC_SUBST(x_LDFLAGS)
-dnl ===================================================================
-dnl Product version
-dnl ===================================================================
-AC_MSG_CHECKING([for product version])
-PRODUCTVERSION=AC_PACKAGE_VERSION
-AC_MSG_RESULT([$PRODUCTVERSION])
-AC_SUBST(PRODUCTVERSION)
-
#
# determine CPU, CPUNAME, GUI, GUIBASE, ...
#
LIB64="lib"
SOLARINC="-I${SRC_ROOT}/include"
-SDKDIR="sdk"
case "$host_os" in
@@ -3460,7 +3451,6 @@ darwin*)
OS=MACOSX
RTL_OS=MacOSX
P_SEP=:
- SDKDIR="LibreOffice${PRODUCTVERSION}_SDK"
case "$host_cpu" in
arm*)
@@ -3945,7 +3935,7 @@ else
INSTDIR=${BUILDDIR}/instdir/${INPATH}
fi
OUTDIR="${SOLARVER}/${INPATH}"
-SOLARINC="-I. -I$SRC_ROOT/include -I${SOLARVER}/$INPATH/inc/external -I${SOLARVER}/$INPATH/inc -I${INSTDIR}/${SDKDIR}/include $SOLARINC"
+SOLARINC="-I. -I$SRC_ROOT/include -I${SOLARVER}/$INPATH/inc/external -I${SOLARVER}/$INPATH/inc $SOLARINC"
AC_SUBST(COM)
AC_SUBST(CPU)
AC_SUBST(CPUNAME)
@@ -11338,6 +11328,14 @@ AC_SUBST(CURL)
AC_SUBST(MD5SUM)
dnl ===================================================================
+dnl Product version
+dnl ===================================================================
+AC_MSG_CHECKING([for product version])
+PRODUCTVERSION=AC_PACKAGE_VERSION
+AC_MSG_RESULT([$PRODUCTVERSION])
+AC_SUBST(PRODUCTVERSION)
+
+dnl ===================================================================
dnl Dealing with l10n options
dnl ===================================================================
AC_MSG_CHECKING([which languages to be built])