summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2015-12-01 10:08:32 +0100
committerStephan Bergmann <sbergman@redhat.com>2015-12-02 08:02:20 +0100
commitc4688ad97e4b5f1c0e7fd94937013ddc1c868139 (patch)
tree30cc8dbe3b917357c5ffb14c5feb09f49f1aaf5c /configure.ac
parent871b5abf1198c6b385eef844fa0c1192ccf42592 (diff)
Allow --disable-pch for clang-cl
...which doesn't support the cl PCH cmd line args yet Change-Id: I0a5a4d6c82138992c6e40b5958a41a7fa0be88ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 75323dcc5607..d180f82888bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4938,11 +4938,11 @@ dnl enable pch by default on windows
dnl enable it explicitely otherwise
AC_MSG_CHECKING([whether to enable pch feature])
ENABLE_PCH=""
-if test "$_os" = "WINNT" -a "$WITH_MINGW" != "yes"; then
- ENABLE_PCH="TRUE"
- AC_MSG_RESULT([yes])
-elif test "$enable_pch" != "no"; then
- if test -n "$enable_pch" && test "$GCC" = "yes"; then
+if test "$enable_pch" != "no"; then
+ if test "$_os" = "WINNT" -a "$WITH_MINGW" != "yes"; then
+ ENABLE_PCH="TRUE"
+ AC_MSG_RESULT([yes])
+ elif test -n "$enable_pch" && test "$GCC" = "yes"; then
ENABLE_PCH="TRUE"
AC_MSG_RESULT([yes])
elif test -n "$enable_pch"; then