summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@suse.cz>2013-01-02 17:04:34 +0100
committerLuboš Luňák <l.lunak@suse.cz>2013-01-02 17:05:10 +0100
commitdc277bc6a1c357fe725db2c567d3e1cf16fb7806 (patch)
tree4e935e6e1279108d50e13fea7665ee20cf851a8f /configure.ac
parentca3aba4cdf766cf33b0dbbe495c9e6f57f069822 (diff)
use MINGW_SYSROOT consistently
Restore all cases to expect /mingw/ included in the path.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 1e6327a1c7e2..59e20c06b841 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5315,8 +5315,8 @@ dnl ===================================================================
if test "$WITH_MINGW" = "yes"; then
AC_MSG_CHECKING([for MinGW sysroot])
sysroot=`$CC -print-sysroot`
- AS_IF([test -d "$sysroot"],
- [MINGW_SYSROOT="$sysroot"
+ AS_IF([test -d "$sysroot"/mingw],
+ [MINGW_SYSROOT="$sysroot"/mingw
AC_MSG_RESULT([$MINGW_SYSROOT])],
[AC_MSG_RESULT([not found])
AC_MSG_ERROR([cannot determine MinGW sysroot])])
@@ -7529,12 +7529,12 @@ if test $enable_python = system; then
dnl How to find out the cross-compilation Python installation path?
dnl Let's hardocode what we know for different distributions for now...
for python_version in 2.6; do
- if test -f ${MINGW_SYSROOT}/mingw/include/python${python_version}/Python.h; then
- PYTHON_CFLAGS="-I${MINGW_SYSROOT}/mingw/include/python$python_version"
- PYTHON_LIBS="-L${MINGW_SYSROOT}/mingw/lib -lpython$python_version $python_libs"
+ if test -f ${MINGW_SYSROOT}/include/python${python_version}/Python.h; then
+ PYTHON_CFLAGS="-I${MINGW_SYSROOT}/include/python$python_version"
+ PYTHON_LIBS="-L${MINGW_SYSROOT}/lib -lpython$python_version $python_libs"
AC_MSG_CHECKING([for python.exe])
- AS_IF([test -f "$MINGW_SYSROOT/mingw/bin/python.exe"],
- [AC_MSG_RESULT([$MINGW_SYSROOT/mingw/bin/python.exe])
+ AS_IF([test -f "$MINGW_SYSROOT/bin/python.exe"],
+ [AC_MSG_RESULT([$MINGW_SYSROOT/bin/python.exe])
MINGW_PYTHON_EXE=python.exe],
[AC_MSG_RESULT([not found])
AC_MSG_ERROR([could not find python.exe])])