summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2016-02-25 21:16:53 +0100
committerStephan Bergmann <sbergman@redhat.com>2016-02-26 08:57:08 +0100
commit4cb9d7d1c49d435d789ede63a89111a6d01260cf (patch)
treeb07c80afdcd37bd6c0dc11c248146beaef5206b3 /configure.ac
parent0fef230f0f58bcdebce56bc0439f7efade99a7c5 (diff)
Assume HAVE_THREADSAFE_STATICS=TRUE for Clang with -stdlib=libc++
Change-Id: I6a38019d5ede6c10b3f33f4a9b078253e4159e71
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 658f2c8f1060..9b1f2dc5c32f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5946,9 +5946,11 @@ if test "$GCC" = "yes"; then
AC_LANG_PUSH([C++])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
#include <list>
-#if !defined __GLIBCXX__ ||(__GLIBCXX__ < 20080606 && __GLIBCXX__ != 20080306)
+#if defined __GLIBCXX__
+#if __GLIBCXX__ < 20080606 && __GLIBCXX__ != 20080306
#error
#endif
+#endif
]])],[HAVE_THREADSAFE_STATICS=TRUE],[])
AC_LANG_POP([C++])
else # known to work in GCC since version 4.3