summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <thorsten.behrens@allotropia.de>2024-01-13 19:42:18 +0100
committerThorsten Behrens <thorsten.behrens@allotropia.de>2024-01-13 21:43:12 +0100
commit0b4510c060dc881fdc7d95379b06a02c413ae051 (patch)
treef975d58bf106159c9d041c8bdcd7a0f20af0f1cb /configure.ac
parent5f7496ddce65f20a09807a394ae986905b999698 (diff)
system poppler cannot be used with dbgutil
Change-Id: I88d68e85c25bdaf6f4a06e00e812ac31cd125dfe Reviewed-on: https://gerrit.libreoffice.org/c/core/+/162019 Tested-by: Jenkins Reviewed-by: Thorsten Behrens <thorsten.behrens@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 299fcba5b011..7bc3f5d65f0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4696,6 +4696,11 @@ if test -n "$enable_dbgutil" -a "$enable_dbgutil" != "no"; then
else
with_system_zxing=no
fi
+ if test "$with_system_poppler" = "yes"; then
+ AC_MSG_ERROR([--with-system-poppler conflicts with --enable-dbgutil])
+ else
+ with_system_poppler=no
+ fi
# As mixing system libwps and non-system libnumbertext or vice versa likely causes trouble (see
# 603074c5f2b84de8a24593faf807da784b040625 "Pass _GLIBCXX_DEBUG into external/libwps" and the
# mail thread starting at <https://gcc.gnu.org/ml/gcc/2018-05/msg00057.html> "libstdc++: ODR