summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTaichi Haradaguchi <20001722@ymail.ne.jp>2023-09-11 19:41:45 +0900
committerStephan Bergmann <sbergman@redhat.com>2023-09-14 09:47:21 +0200
commit0ff322adfecec99751b249bac0c75b02ac570bf0 (patch)
treea1569e955de7305d6bcf0eec479ab0f23927f4cf /configure.ac
parentd50e5d6d53c94124f825758a74e186b934fc2a4e (diff)
Latest VS 2022 Preview is 17.8.0 now
...while latest proper VS 2022 is 17.7.4 Change-Id: I949913ffd79a338b2792ad9baa88532a1406cf4a Reviewed-on: https://gerrit.libreoffice.org/c/core/+/156820 Tested-by: Stephan Bergmann <sbergman@redhat.com> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 5a682dde4d61..be1c11e45d38 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4004,7 +4004,7 @@ map_vs_year_to_version()
2022)
vsversion=17;;
2022preview)
- vsversion=17.7;;
+ vsversion=17.8;;
*)
AC_MSG_ERROR([Assertion failure - invalid argument "$1" to map_vs_year_to_version()]);;
esac
@@ -4124,7 +4124,7 @@ find_msvc()
vcyear=2019
vctoolset=v142
;;
- 17.0 | 17.7)
+ 17.0 | 17.8)
vcyear=2022
vctoolset=v143
;;
@@ -4296,7 +4296,7 @@ if test "$_os" = "WINNT"; then
# are always "better", we list them in reverse chronological order.
case "$vcnumwithdot" in
- 16.0 | 17.0 | 17.7)
+ 16.0 | 17.0 | 17.8)
WINDOWS_SDK_ACCEPTABLE_VERSIONS="10.0 8.1A 8.1 8.0"
;;
esac
@@ -6647,7 +6647,7 @@ find_msms()
msmdir=
case "$VCVER" in
- 16.0 | 17.0 | 17.7)
+ 16.0 | 17.0 | 17.8)
for l in `ls -1 $VC_PRODUCT_DIR/redist/MSVC/`; do
my_msm_dir="$VC_PRODUCT_DIR/redist/MSVC/$l/MergeModules/"
echo "$as_me:$LINENO: looking for $my_msm_dir${my_msm_file}])" >&5
@@ -6683,7 +6683,7 @@ find_msvc_x64_dlls()
msvcdllpath="$VC_PRODUCT_DIR/redist/x64/Microsoft.VC${VCVER}.CRT"
case "$VCVER" in
- 16.0 | 17.0 | 17.7)
+ 16.0 | 17.0 | 17.8)
for crtver in 141 142 143; do
for l in `ls -1 $VC_PRODUCT_DIR/redist/MSVC/`; do
echo "$as_me:$LINENO: testing $VC_PRODUCT_DIR/redist/MSVC/$l/x64/Microsoft.VC$crtver.CRT" >&5