summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHeiko Tietze <tietze.heiko@gmail.com>2021-01-08 15:10:42 +0100
committerMiklos Vajna <vmiklos@collabora.com>2021-01-14 09:25:07 +0100
commit2d69acfde50cb0e06a9a057939078fd102d371a3 (patch)
treefa6e06401d482d225b2e9f14a37a0a943de2ba45 /configure.ac
parent06322b0922972fec4b9e5f57e8dbab18ca9bd676 (diff)
Resolves tdf#139343 and tdf#139335 - Community/Enterprise flavor
* Switch CE/EE per --disable-community-flavor internally use HAVE_FEATURE_COMMUNITY_FLAVOR * Version info in about dialog shows text depending on this flavor * Start center also shows the brand image now * TDF builds use a brand image with TDF tagline in the about dialog * Brand images with just "Community" (no Edition) Change-Id: I363dd2b39df9aad951c9d79addf9bdedfc4a3495 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108980 Tested-by: Jenkins Reviewed-by: Heiko Tietze <heiko.tietze@documentfoundation.org> Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e845f60a26dd..562d0141e6cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1738,6 +1738,11 @@ AC_ARG_WITH(product-name,
[Define the product name. Default is AC_PACKAGE_NAME.]),
,with_product_name=$PRODUCTNAME)
+libo_FUZZ_ARG_ENABLE(community-flavor,
+ AS_HELP_STRING([--disable-community-flavor],
+ [Disable the Community branding.]),
+,)
+
AC_ARG_WITH(package-version,
AS_HELP_STRING([--with-package-version='3.1.4.5'],
[Define the package version. Default is AC_PACKAGE_VERSION. Use only if you distribute an own build for macOS.]),
@@ -2612,6 +2617,14 @@ fi
AC_SUBST(ENABLE_RELEASE_BUILD)
AC_SUBST(GET_TASK_ALLOW_ENTITLEMENT)
+AC_MSG_CHECKING([whether to build a Community flavor])
+if test -z "$enable_community_flavor" -o "$enable_community_flavor" == "yes"; then
+ AC_DEFINE(HAVE_FEATURE_COMMUNITY_FLAVOR)
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl ===================================================================
dnl Test whether to sign Windows Build
dnl ===================================================================
@@ -13335,7 +13348,7 @@ dnl ===================================================================
AC_MSG_CHECKING([for alternative branding images directory])
# initialize mapped arrays
BRAND_INTRO_IMAGES="intro.png intro-highres.png"
-brand_files="$BRAND_INTRO_IMAGES logo.svg logo_inverted.svg about.svg"
+brand_files="$BRAND_INTRO_IMAGES logo.svg logo_inverted.svg logo-sc.svg logo-sc_inverted.svg about.svg"
if test -z "$with_branding" -o "$with_branding" = "no"; then
AC_MSG_RESULT([none])