summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <stephan.bergmann@allotropia.de>2024-03-20 15:02:02 +0100
committerStephan Bergmann <stephan.bergmann@allotropia.de>2024-03-20 21:51:47 +0100
commit31b18d5a5f652dc1bb82ec2828e5f3a951590301 (patch)
treef92a8ceda92cf00c4d84414d4771294105dd0d55 /configure.ac
parent0633e4b4205334dd65ec64d7f3e306ee125e31be (diff)
Allow extra options in JAVACOMPILER env var
...similar to how we support this for other vars like CC and CXX. (I currently need this to add -J-Xint to JAVACOMPILER in an attempt to work around the issue described in <https://blogs.oracle.com/java/post/java-on-macos-14-4> where macOS now sends uncatchable SIGKILL instead of SIGSEGV to the JVM process in response to a Java null pointer deref.) Change-Id: Ie677f97aeca983af7d8ef23e3794103ae30ae0b6 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/165065 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <stephan.bergmann@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 81d9ec93ac19..e03fa2363f03 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14165,7 +14165,7 @@ if test "$ENABLE_JAVA" != "" -a "$with_junit" != "no" -a "$cross_compiling" != "
OOO_JUNIT_JAR=`cygpath -m "$OOO_JUNIT_JAR"`
fi
printf 'import org.junit.Before;' > conftest.java
- if "$JAVACOMPILER" -classpath "$OOO_JUNIT_JAR" conftest.java >&5 2>&5; then
+ if $JAVACOMPILER -classpath "$OOO_JUNIT_JAR" conftest.java >&5 2>&5; then
AC_MSG_RESULT([$OOO_JUNIT_JAR])
else
AC_MSG_ERROR(
@@ -14179,7 +14179,7 @@ if test "$ENABLE_JAVA" != "" -a "$with_junit" != "no" -a "$cross_compiling" != "
AC_MSG_CHECKING([for included Hamcrest])
printf 'import org.hamcrest.BaseDescription;' > conftest.java
- if "$JAVACOMPILER" -classpath "$OOO_JUNIT_JAR" conftest.java >&5 2>&5; then
+ if $JAVACOMPILER -classpath "$OOO_JUNIT_JAR" conftest.java >&5 2>&5; then
AC_MSG_RESULT([Included in $OOO_JUNIT_JAR])
else
AC_MSG_RESULT([Not included])
@@ -14200,7 +14200,7 @@ if test "$ENABLE_JAVA" != "" -a "$with_junit" != "no" -a "$cross_compiling" != "
if test "$_os" = "WINNT"; then
HAMCREST_JAR=`cygpath -m "$HAMCREST_JAR"`
fi
- if "$JAVACOMPILER" -classpath "$HAMCREST_JAR" conftest.java >&5 2>&5; then
+ if $JAVACOMPILER -classpath "$HAMCREST_JAR" conftest.java >&5 2>&5; then
AC_MSG_RESULT([$HAMCREST_JAR])
else
AC_MSG_ERROR([junit does not contain hamcrest; please use a junit jar that includes hamcrest, install a hamcrest jar in the default location (/usr/share/java),