summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2022-05-17 11:42:25 +0300
committerTor Lillqvist <tml@collabora.com>2022-05-17 12:41:37 +0200
commit42eeb373978deb660f38707babfc9d5af9da5cd9 (patch)
treeac55580517bedbe382d004f11c30486e97006a44 /configure.ac
parent0b582183902cfd1de13ad4748d80dc4a9257f3f4 (diff)
AC_RUN_IFELSE won't work when cross-compiling
Change-Id: I8e4d439f0e03ca9e9e3088b451efd8d09bf37203 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/134462 Tested-by: Jenkins Reviewed-by: Tor Lillqvist <tml@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3ba32994cb96..34ba3f7844e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7420,7 +7420,7 @@ AC_SUBST([HAVE_LIBSTDCPP])
AC_SUBST([HAVE_LIBCPP])
HAVE_LIBCPP_DEBUG=
-if test -n "$HAVE_LIBCPP" -a -n "$ENABLE_DBGUTIL"; then
+if test -z "$CROSS_COMPILING" -a -n "$HAVE_LIBCPP" -a -n "$ENABLE_DBGUTIL"; then
# Libc++ supports debug mode only if built for it, Mac libc++ isn't,
# and there would be undefined references to debug functions.
# Moreover std::to_string() has a bug (https://reviews.llvm.org/D125184).