summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-10-01 14:09:51 +0200
committerStephan Bergmann <sbergman@redhat.com>2019-10-01 23:32:10 +0200
commit463a79cbc16c1b4aba1775d7f8ae0324753c322c (patch)
treea3a3fa4329839f24e34d919cf11e43e8f1b0e36f /configure.ac
parente25758ac95380965aba486e1eae62f144d389185 (diff)
CXX_X64_BINARY must be clang-cl not cl when building with clang-cl
...to avoid failures like > [build CXX] shell/source/win32/spsupp/registrar_x64.cxx > cl : Command line error D8021 : invalid numeric argument '/Wendif-labels' after 58ef8c188b6bb2ed307f5e825cc7e475c33d0c33 "Make spsupp*.dll usable on 64- bit Windows". This is a bit of a hack, relying on CXX being passed in via autogen.input in my clang-cl build. Ideally, the code would be reorganized so that CXX_X64_BINARY is only set after CXX has been set. Change-Id: Ia2c823ad6b917218858ea541cc6a65fa423e3a09 Reviewed-on: https://gerrit.libreoffice.org/79959 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 30bd03c24123..9de464819664 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3617,7 +3617,7 @@ if test "$_os" = "WINNT"; then
AC_MSG_WARN([Installation set will not contain 64-bit Explorer extensions])
fi
else
- CXX_X64_BINARY=$MSVC_CXX
+ CXX_X64_BINARY=${CXX:-$MSVC_CXX}
fi
AC_SUBST(BUILD_X64)