summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <michael.stahl@allotropia.de>2021-03-14 11:45:10 +0100
committerMichael Stahl <michael.stahl@allotropia.de>2021-03-15 13:15:03 +0100
commit4927e8277d0a9740c0d52015bbcb8571081b721c (patch)
tree0609d0263ad7517115905e9e0cd9d238c6fc85e6 /configure.ac
parent67ad205404211a2ae17c430a17ede6e9d04d0b7e (diff)
configure: fix detection of CLANGDIR
... for values of CXX like "sccache clang++" - take the first word that contains "clang". Change-Id: Icb4406fdaad73e593e5d7086bc726f8e1b017acd Reviewed-on: https://gerrit.libreoffice.org/c/core/+/112479 Tested-by: Jenkins Reviewed-by: Michael Stahl <michael.stahl@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fece7f768759..fe84f7b4e922 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7802,7 +7802,7 @@ if test "$COM_IS_CLANG" = "TRUE"; then
dnl The prefix where Clang resides, override to where Clang resides if
dnl using a source build:
if test -z "$CLANGDIR"; then
- CLANGDIR=$(dirname $(dirname $($CXX -print-prog-name=$(basename $(printf '%s\n' $CXX | head -n 1)))))
+ CLANGDIR=$(dirname $(dirname $($CXX -print-prog-name=$(basename $(printf '%s\n' $CXX | grep clang | head -n 1)))))
fi
# Assume Clang is self-built, but allow overriding COMPILER_PLUGINS_CXX to the compiler Clang was built with.
if test -z "$COMPILER_PLUGINS_CXX"; then