summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTaichi Haradaguchi <20001722@ymail.ne.jp>2023-08-06 11:32:18 +0200
committerTaichi Haradaguchi <20001722@ymail.ne.jp>2023-08-07 05:59:22 +0200
commit5cd48b4969d25400cc6634fb64706a763528ec65 (patch)
treec0a30ff3efeb2b09606ff68a4293fc4f22e913ef /configure.ac
parent6e12b7f296930c6f37e036407e9fb832d9a9f027 (diff)
Revert "tdf#116412: include bz2 in internal python"
This reverts commit 5e3510dbb62229cfb01da371d39ecc27b0d44880. Reason for revert: occured build error at https://ci.libreoffice.org/view/tb%20platform%20status/job/lo_daily_tb_win_arm64/966/ Change-Id: I9f9087964f7a85c03bca6be4eff5717d6d274c89 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/155391 Tested-by: Jenkins Reviewed-by: Taichi Haradaguchi <20001722@ymail.ne.jp>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 9596d04b117f..7f5c0ff66430 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2192,8 +2192,7 @@ AC_ARG_WITH(system-libs,
AC_ARG_WITH(system-bzip2,
AS_HELP_STRING([--with-system-bzip2],
- [Use bzip2 already on system. Used when --enable-online-update=mar
- or --enable-python=internal]),,
+ [Use bzip2 already on system. Used only when --enable-online-update=mar]),,
[with_system_bzip2="$with_system_libs"])
AC_ARG_WITH(system-headers,
@@ -13551,16 +13550,17 @@ AC_SUBST(PRIVACY_POLICY_URL)
dnl ===================================================================
dnl Test whether we need bzip2
dnl ===================================================================
-if test "$ENABLE_ONLINE_UPDATE_MAR" = "TRUE" -o "$enable_python" = "internal"; then
+SYSTEM_BZIP2=
+if test "$ENABLE_ONLINE_UPDATE_MAR" = "TRUE"; then
AC_MSG_CHECKING([whether to use system bzip2])
if test "$with_system_bzip2" = yes; then
- AC_MSG_RESULT([external])
SYSTEM_BZIP2=TRUE
- AC_CHECK_HEADER(bzlib.h, [], [AC_MSG_ERROR(bzlib.h not found. please install bzip2.)], [])
- AC_CHECK_LIB([bz2], [BZ2_bzDecompressInit], [:], [AC_MSG_ERROR(libbz2 not found or functional.)], [])
+ AC_MSG_RESULT([yes])
+ PKG_CHECK_MODULES(BZIP2, bzip2)
+ FilterLibs "${BZIP2_LIBS}"
+ BZIP2_LIBS="${filteredlibs}"
else
- AC_MSG_RESULT([internal])
- SYSTEM_BZIP2=
+ AC_MSG_RESULT([no])
BUILD_TYPE="$BUILD_TYPE BZIP2"
fi
fi