summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2024-04-26 13:03:49 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2024-04-27 10:16:39 +0200
commit9d7548dafb44c1f0af82771a597db1404659af66 (patch)
treed17f6ba5413fda06e77d9013f204587bd47c5bf2 /configure.ac
parent535391b31abafb02e5a4451e30a14a5605d05ff4 (diff)
fix some hardcoded use of wsl.exe and fix some typos
Change-Id: I6152ee61913638f828eeb201ecb26312de5f8572 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/166737 Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> Tested-by: Jenkins
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 1650686382ef..e04f4a846642 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,7 +337,8 @@ if test -n "$WSL_DISTRO_NAME" && $(echo $PATH |grep -q mingw64); then
STRAWBERRY_PERL="$formatted_path/perl/bin/perl.exe"
AC_ARG_WITH([wsl-command],
[AS_HELP_STRING([--with-wsl-command],
- [Specify your wsl distro command if it isn't the default/the one used with just wsl.exe])],
+ [Specify your wsl distro command if it isn't the default/the one used with just wsl.exe –
+ for example: wsl.exe -d MyDistro -u NonDefaultUser])],
[],
[with_wsl_command="wsl.exe"])
WSL="$with_wsl_command"
@@ -15468,10 +15469,11 @@ if test -n "$WSL_ONLY_AS_HELPER"; then
PERL="perl.exe"
# use flex, gperf and nasm from wsl-container
# if using absolute path, would need to use double-leading slash for the msys path mangling
- FLEX="wsl.exe $FLEX"
- NASM="wsl.exe $NASM"
- # some externals (libebook) checks with AC_PATH_PROGS, and that requires argument to begin with slash...
- GPERF="/c/Windows/system32/wsl.exe gperf"
+ FLEX="$WSL $FLEX"
+ NASM="$WSL $NASM"
+ # some externals (libebook) check for it with AC_PATH_PROGS, and that only accepts overrides
+ # with an absolute path/requires the value to begin with a slash
+ GPERF="/c/Windows/system32/$WSL gperf"
# append strawberry tools dir to PATH (for e.g. windres, ar)
LO_PATH="$LO_PATH:$STRAWBERRY_TOOLS"
# temp-dir needs to be in windows realm, hardcode for now