summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Nabet <serval2412@yahoo.fr>2024-05-25 13:27:36 +0200
committerStephan Bergmann <stephan.bergmann@allotropia.de>2024-05-27 10:00:09 +0200
commita9f77afabf98d98e14308a82aab86a2a3715fced (patch)
tree05024bab6872af4d0fa45f7b4b23810eeb7b1da4 /configure.ac
parent73064240850c78e93ee6c534a388aba617e4c234 (diff)
Bump emscripten minimum to 2.0.32 for as_handle
Reading https://github.com/emscripten-core/emscripten/blob/main/ChangeLog.md val::as_handle() has been added with 2.0.32 It'll allow WASM Jenkins to fail at the configure check step instead in the build with: /home/tdf/jenkins/workspace/lo_gerrit/tb/src_wasm/static/source/unoembindhelpers/PrimaryBindings.cxx:231:37: error: no member named 'as_handle' in 'emscripten::val' = _emval_as(rObject.as_handle(), getTypeId(rUnoType), &destructors); ~~~~~~~ ^ /home/tdf/jenkins/workspace/lo_gerrit/tb/src_wasm/static/source/unoembindhelpers/PrimaryBindings.cxx:240:37: error: no member named 'as_handle' in 'emscripten::val' = _emval_as(rObject.as_handle(), getTypeId(rUnoType), &destructors); ~~~~~~~ ^ 2 errors generated. Change-Id: I7531256de46cd4b86b6eac9b1f8d16cad7b46ae2 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/168035 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <stephan.bergmann@allotropia.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 88dd106f574a..22c95079f2d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1433,7 +1433,7 @@ dnl ===================================================================
EMSCRIPTEN_MIN_MAJOR=2
EMSCRIPTEN_MIN_MINOR=0
-EMSCRIPTEN_MIN_TINY=31
+EMSCRIPTEN_MIN_TINY=32
EMSCRIPTEN_MIN_VERSION="${EMSCRIPTEN_MIN_MAJOR}.${EMSCRIPTEN_MIN_MINOR}.${EMSCRIPTEN_MIN_TINY}"
if test "$_os" = "Emscripten"; then