summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2019-04-09 23:12:10 +0200
committerStephan Bergmann <sbergman@redhat.com>2019-04-10 09:43:00 +0200
commitaabafa92a5d66a9d706125b88bfca55fd3ca6473 (patch)
tree29d51f1b978c91b64fc8bf9cd7e906570d854616 /configure.ac
parent3c24774d85a8c0ac03faa4ba2b82c8c9dfe0a2b3 (diff)
Honor use_ld_fail_if_error in use_ld_has_sanitizers check
Change-Id: I20ed4c7daa9cde48ba65f92e5b4cc7e00972fe81 Reviewed-on: https://gerrit.libreoffice.org/70477 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 457511f063c5..5f4a6de14dcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3887,7 +3887,11 @@ printf ("hello world\n");
if test -n "$use_ld_has_cpp_typeinfo"; then
AC_MSG_RESULT( yes )
else
- AC_MSG_RESULT( no )
+ if test -n "$use_ld_fail_if_error"; then
+ AC_MSG_ERROR( no )
+ else
+ AC_MSG_RESULT( no )
+ fi
use_ld_ok=
fi
fi