summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Marek Glogowski <glogow@fbihome.de>2020-09-14 15:24:37 +0200
committerJan-Marek Glogowski <glogow@fbihome.de>2020-09-15 01:01:45 +0200
commitabcc4eb907661e07ad850ccce7eb06f129da4286 (patch)
treefeab97293f3d4d7aae9d2f02e5ccdb0d13378200 /configure.ac
parent89b385c2336e5b3868d2a040e11134b349b7d010 (diff)
cross-build: JAVA_HOME is now build, not host
Miklos reported a Android configure error, which tried to run autogen.sh for gb_Side=build, which is correctly forbidden. I checked all the files timestamps for $(BUILDDIR)/config_host.mk target - all ok, and somehow missed the JAVA_HOME test... Since my commit 42aeb9f906ca4e23d118ff8563184f9315ef3b82 ("cross-build: fix Java NI linking"), JAVA_HOME just makes sense for the build side. So the tests just make sense for the host side, if there was a --with-jdk-home supplied. This results in a sensible, empty JAVA_HOME for the host side and all Java builds I found already override JAVA_HOME with JAVA_HOME_FOR_BUILD. Change-Id: I1742a83466af70804f1700a1ca0cb6b6b77a7b12 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/102676 Tested-by: Jenkins Reviewed-by: Jan-Marek Glogowski <glogow@fbihome.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 06398bfa99a7..c5ab4159e17f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7901,7 +7901,7 @@ fi
AC_SUBST(JAVADOC)
AC_SUBST(JAVADOCISGJDOC)
-if test "$ENABLE_JAVA" != ""; then
+if test "$ENABLE_JAVA" != "" -a \( "$cross_compiling" != "yes" -o -n "$with_jdk_home" \); then
# check if JAVA_HOME was (maybe incorrectly?) set automatically to /usr
if test "$JAVA_HOME" = "/usr" -a "x$with_jdk_home" = "x"; then
if basename $(readlink $(readlink $JAVACOMPILER)) >/dev/null 2>/dev/null; then