summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLionel Elie Mamane <lionel@mamane.lu>2013-05-13 08:24:49 +0200
committerLionel Elie Mamane <lionel@mamane.lu>2013-05-13 08:25:20 +0200
commitba26c5e6330f5f1f38aab698b2b2c32cac7b5df3 (patch)
treec2281bebc68f2876df36ee9200f900cc71b273a8 /configure.ac
parent14a6eab0cbd3b60937177863a23dae28b555561c (diff)
configure.ac: don't use python2 values for python3
unset more internal python-related variables, so that the test for runtime-python >=3 does not reuse *any* value from test for build-python >= 2.5 Change-Id: I508292713d582476db70fcd2b05ce0abb300f38a
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index efa1b777e7db..dc578d73a4ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7462,7 +7462,7 @@ no|disable)
else
# Unset variables set by the above AM_PATH_PYTHON so that
# we actually do check anew.
- unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON
+ unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
AM_PATH_PYTHON([3.3],, [:])
if test "$PYTHON" = :; then
AC_MSG_RESULT([internal])
@@ -7515,7 +7515,7 @@ if test $enable_python = system; then
elif test "$cross_compiling" != yes; then
# Unset variables set by the above AM_PATH_PYTHON so that
# we actually do check anew.
- unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON
+ unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
# This causes an error if no python command is found
AM_PATH_PYTHON([3.3])
python_include=`$PYTHON -c "import distutils.sysconfig; print(distutils.sysconfig.get_config_var('INCLUDEPY'));"`