summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2021-03-12 14:24:33 +0100
committerStephan Bergmann <sbergman@redhat.com>2021-03-15 10:02:31 +0100
commitc18e5fd7d6c85d4755f1a70d97336d07b2add510 (patch)
treea4933d148f183bca20f4a48cc8a32c18de2ce928 /configure.ac
parent5d83d14ef8e3a149f2dbcddc18a70edda021fbfe (diff)
GCC trunk already calls it C++23
...since <https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=78739c2df788ee5c868d998a6333d453317d8711> "c++: Add support for -std=c++23" Change-Id: I28e345b4130f04eb37a1acb736a4ccbf2f577451 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/112392 Tested-by: Jenkins Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90b0cf01633b..fece7f768759 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7055,7 +7055,7 @@ if test "$COM" = MSC -a "$COM_IS_CLANG" != TRUE; then
elif test "$GCC" = "yes" -o "$COM_IS_CLANG" = TRUE; then
my_flags='-std=c++17 -std=c++1z'
if test "$with_latest_c__" = yes; then
- my_flags="-std=c++2b -std=c++20 -std=c++2a $my_flags"
+ my_flags="-std=c++23 -std=c++2b -std=c++20 -std=c++2a $my_flags"
fi
for flag in $my_flags; do
if test "$COM" = MSC; then