summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-04-01 12:41:18 +0200
committerMichael Stahl <mstahl@redhat.com>2013-04-03 10:17:08 +0000
commitd719c01c2f112d97b09aee008f9bfee57719eeed (patch)
tree6e2bb0c78cf3aa1b0561329c8fe4445fb49b5ce9 /configure.ac
parent78bec2b6f40144277464a64a9851d1dc940ed336 (diff)
Easter Bunny brings new redland tarballs
upgrade raptor to 2.0.9, rasqal to 0.9.30, redland to 1.0.16: - new raptor depends on libxml2 version 2.6.27 and thus will _not_ build against system libxml2 on Mac OS X 10.4/10.5 - stop delivering raptor-config/rasqal-config, set env vars instead (which unfortunately requires patching configures, TODO: upstream that) - remove redundant configure flags - stop passing -Wl,no-inhibit-exec (causes HP-UX code to be built on Linux) - disable new rasqal build deps: --with-uuid-library=internal --with-digest-library=internal - disable redland "libltdl" nonsense via --disable-modular - fortunately openssl digest support has been removed too - drop raptor-1.4.18.ooo_build.patch, set RAPTOR2_CFLAGS/LIBS instead - drop raptor-1.4.18.autotools.patch: + FreeBSD parts moved to raptor-freebsd.patch.1 + Android parts obsolete + don't know about the MinGW part (TODO) - from drop raptor-1.4.18.mingw.patch dropped the part defining parsers to be built, done via --enable-parsers - drop redland/raptor/raptor-1.4.18.cross.patch: the vsnprintf check is now done at runtime, and expat has been removed - drop raptor-1.4.18.aix.patch,redland-1.0.8.aix.patch: presumably don't need special check for V7BETA since it's released now - drop raptor-1.4.18.rindex.patch, index/rindex no longer used - drop raptor-1.4.18.entities.patch, fixed upstream in 2.0.7 - drop raptor-1.4.18.fixes.patch, fixed upstream in 2.0.9 - drop raptor-1.4.18.{libxml,libxslt}.patch: TODO - drop {raptor-1.4.18,rasqal-0.9.16,redland-1.0.8}.legal.patch: we don't care any more about Sun legal dept. - drop rasqal-0.9.16.ooo_build.patch, set RASQAL_CFLAGS/LIBS instead - drop rasqal-0.9.16.autotools.patch: + FreeBSD parts moved to rasqal-freebsd.patch.1 + Android parts obsolete + MinGW part only for cygwin build - drop redland-1.0.8.autotools.patch: + FreeBSD parts moved to redland-freebsd.patch.1 + Android parts obsolete + don't know about the MinGW part (TODO) - drop redland-1.0.8.ooo_build.patch, hopefully not necessary to disable utils build Change-Id: I9cc44928ba87392d69e809abe2236cec0e4a508a Reviewed-on: https://gerrit.libreoffice.org/3154 Tested-by: LibreOffice gerrit bot <gerrit@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 598e7dac0368..1f4e2b11439c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8581,8 +8581,8 @@ if test "$with_system_redland" = "yes"; then
libo_MINGW_TRY_DLL([RASQAL], [librasqal])
libo_MINGW_TRY_DLL([SQLITE3], [libsqlite3])
else
- RAPTOR_MAJOR="1"
- RASQAL_MAJOR="1"
+ RAPTOR_MAJOR="0"
+ RASQAL_MAJOR="3"
REDLAND_MAJOR="0"
fi
AC_SUBST(RAPTOR_MAJOR)