summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Weghorn <m.weghorn@posteo.de>2019-05-31 09:29:17 +0200
committerMichael Weghorn <m.weghorn@posteo.de>2019-06-15 09:28:26 +0200
commitd947042124d5027068395767e628845af944d005 (patch)
tree1b63c9ddac7405f72bbd42b704cb7af9e55d018c /configure.ac
parent2ab93756963727b8dde43b405e2daee3e1bf9deb (diff)
Have all VCL plugin related defines in config_vclplug.h
Add the 'ENABLE_GTK3' and 'ENABLE_QT5' there to allow using sth like #include <config_vclplug.h> #if ENABLE_GTK3 // your code here #endif for these as well. Remove 'config_gtk3_kde5.h{,.in}', 'config_kde5.h{,.in}' and 'config_qt5.h{,.in}'; they aren't included anywhere. ('QT5_HAVE_GLIB' is only used in Makefiles, so there's no need to have it in a config header and 'KDE5_HAVE_GLIB' is not used anywhere at all.) Change-Id: Iea7906880f57dde782c50f2520e8d9b358f6bc82 Reviewed-on: https://gerrit.libreoffice.org/73204 Tested-by: Jenkins Reviewed-by: Katarina Behrens <Katarina.Behrens@cib.de> (cherry picked from commit 593e8c671361ba5a1229001ce9d1da92f4aae842) Reviewed-on: https://gerrit.libreoffice.org/74080 Reviewed-by: Michael Weghorn <m.weghorn@posteo.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 39dd082b8366..af54cc66fc44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10343,6 +10343,7 @@ if test "x$enable_gtk3" = "xyes"; then
: ${with_system_cairo:=yes}
PKG_CHECK_MODULES(GTK3, gtk+-3.0 >= 3.18 gtk+-unix-print-3.0 gmodule-no-export-2.0 glib-2.0 >= 2.38 cairo, ENABLE_GTK3="TRUE", ENABLE_GTK3="")
if test "x$ENABLE_GTK3" = "xTRUE"; then
+ AC_DEFINE(ENABLE_GTK3)
R="gtk3"
dnl Avoid installed by unpackaged files for now.
if test -z "$PKGFORMAT"; then
@@ -11285,7 +11286,6 @@ the root of your Qt installation by exporting QT5DIR before running "configure".
PKG_CHECK_MODULES(QT5_GLIB,[glib-2.0 >= 2.4],
[
QT5_HAVE_GLIB=1
- AC_DEFINE(QT5_HAVE_GLIB,1)
],
AC_MSG_WARN([[No Glib found, Qt5 support will not use native file pickers!]])
)
@@ -12866,9 +12866,6 @@ AC_CONFIG_HEADERS([config_host/config_liblangtag.h])
AC_CONFIG_HEADERS([config_host/config_libnumbertext.h])
AC_CONFIG_HEADERS([config_host/config_locales.h])
AC_CONFIG_HEADERS([config_host/config_mpl.h])
-AC_CONFIG_HEADERS([config_host/config_qt5.h])
-AC_CONFIG_HEADERS([config_host/config_kde5.h])
-AC_CONFIG_HEADERS([config_host/config_gtk3_kde5.h])
AC_CONFIG_HEADERS([config_host/config_oox.h])
AC_CONFIG_HEADERS([config_host/config_options.h])
AC_CONFIG_HEADERS([config_host/config_options_calc.h])