summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorStephan Bergmann <sbergman@redhat.com>2017-11-02 11:39:44 +0100
committerStephan Bergmann <sbergman@redhat.com>2017-11-02 11:39:44 +0100
commite335dab103f1f917c527664f8c7ff9babe5e83cb (patch)
tree448fa9e03ad6f54d99127d8f717dc9372b8b38de /configure.ac
parent3133f128038fbc6e9964ebd637c05401c13d77ac (diff)
Document when HAVE_BROKEN_CONST_ITERATORS can go
Change-Id: I96636cbff097af77bc0ccd669b6a973c282f7360
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 162e779427c0..2744367421c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12055,6 +12055,11 @@ if test "$build_os" = "cygwin"; then
AC_SUBST(ILIB)
fi
+dnl We should be able to drop the below check when bumping the GCC baseline to
+dnl 4.9, as <https://gcc.gnu.org/bugzilla/show_bug.cgi?id=54577>
+dnl "deque<T>::erase() still takes iterator instead of const_iterator" should be
+dnl fixed there with <https://gcc.gnu.org/git/?p=gcc.git;a=commit;
+dnl h=6b0e18ca48bb4b4c01e7b5be2b98849943fdcf91>:
AC_MSG_CHECKING(
[whether C++11 use of const_iterator in standard containers is broken])
save_CXXFLAGS=$CXXFLAGS