summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@centrum.cz>2021-11-29 16:07:52 +0100
committerLuboš Luňák <l.lunak@collabora.com>2021-11-29 22:54:01 +0100
commite9332dcdc8f2ea268d1b17c73d43a8834cf75365 (patch)
tree1735cd809434a3f418be9d44e360793ccfdcb96a /configure.ac
parent84783cc90b504b114f9adc94955253a5cf382abb (diff)
explicitly check also for -fno-pch-codegen
The catch is that clang-cl does not know it, it only understands -Xclang -fpch-codegen. On Linux -fno-pch-codegen is handled by the driver, but clang-cl doesn't know the options, so we pass to the backend using -Xclang, but that one understands only -fpch-codegen. So if not found, do not use that option, the cost is only that compiling precompiled_skia.cxx will take longer. Change-Id: Ie307f96b381b732517a5ab574c742a2ee0bfb687 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/126067 Tested-by: Jenkins Reviewed-by: Luboš Luňák <l.lunak@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 65a38d685c73..140ee52e675f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6014,10 +6014,11 @@ if test -n "$BUILDING_PCH_WITH_OBJ"; then
save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -Werror ${fpch_prefix}-fpch-codegen"
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],
- [
- PCH_CODEGEN="${fpch_prefix}-fpch-codegen"
- PCH_NO_CODEGEN="${fpch_prefix}-fno-pch-codegen"
- ],[])
+ [ PCH_CODEGEN="${fpch_prefix}-fpch-codegen" ],[])
+ CFLAGS=$save_CFLAGS
+ CFLAGS="$CFLAGS -Werror ${fpch_prefix}-fno-pch-codegen"
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[ return 0; ]])],
+ [ PCH_NO_CODEGEN="${fpch_prefix}-fno-pch-codegen" ],[])
CFLAGS=$save_CFLAGS
if test -n "$PCH_CODEGEN"; then
AC_MSG_RESULT(yes)