summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThorsten Behrens <Thorsten.Behrens@CIB.de>2020-03-25 16:42:31 +0100
committerVasily Melenchuk <vasily.melenchuk@cib.de>2020-12-05 19:21:17 +0300
commitf29353b0a7a935c4078366f2c9356ce2663c679d (patch)
tree4e723a28d0ef404d0eec2d5b69f6ae38a4ba0909 /configure.ac
parentd7be49157f3b9965b45f244eb98b2421263a0f23 (diff)
Remove option to build against system Python
With python3: upgrade to release 3.5.9 we only support internal python builds on this LTS branch. Change-Id: Ib7f9ab86c767b76a94b350b8ab0bcd413a8b2a62
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 4 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index a62c131a6d0e..c581d3c0a7ba 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8647,23 +8647,12 @@ no|disable)
AC_MSG_RESULT([system])
enable_python=system
else
- # Unset variables set by the above AM_PATH_PYTHON so that
- # we actually do check anew.
- AC_MSG_RESULT([])
- unset PYTHON am_cv_pathless_PYTHON ac_cv_path_PYTHON am_cv_python_version am_cv_python_platform am_cv_python_pythondir am_cv_python_pyexecdir
- AM_PATH_PYTHON([3.3],, [:])
- AC_MSG_CHECKING([which Python to use for Pyuno])
- if test "$PYTHON" = ":"; then
- if test -z "$PYTHON_FOR_BUILD"; then
- AC_MSG_RESULT([fully internal])
- else
- AC_MSG_RESULT([internal])
- fi
- enable_python=internal
+ if test -z "$PYTHON_FOR_BUILD"; then
+ AC_MSG_RESULT([fully internal])
else
- AC_MSG_RESULT([system])
- enable_python=system
+ AC_MSG_RESULT([internal])
fi
+ enable_python=internal
fi
;;
internal)