summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorIvo Hinkelmann <ihi@openoffice.org>2011-02-17 16:39:56 +0100
committerIvo Hinkelmann <ihi@openoffice.org>2011-02-17 16:39:56 +0100
commit42d31088dd0bd1ebb24c1c278e0a6320efdf1239 (patch)
treeffe4ff7cdd09da266186b207ffd8dac01c3a2142 /configure.in
parent3d9a9a561d5ea35c9805fff6b31a97db77bf479e (diff)
parentdd687af86d041fbd420be084e6a063fb41a1d86a (diff)
CWS-TOOLING: integrate CWS locales34
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 16 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 92add6148851..eca0540550a5 100644
--- a/configure.in
+++ b/configure.in
@@ -4657,6 +4657,7 @@ if test -n "$with_system_icu" -o -n "$with_system_libs" && \
AC_LANG_PUSH([C++])
AC_MSG_CHECKING([for unicode/rbbi.h])
AC_TRY_CPP(unicode/rbbi.h, AC_MSG_RESULT([checked.]), AC_MSG_ERROR([icu headers not found.]))
+ AC_LANG_POP([C++])
AC_PATH_PROG(SYSTEM_GENBRK, genbrk, [], [$PATH:/usr/sbin:/sbin])
if test -z "$SYSTEM_GENBRK"; then
AC_MSG_ERROR([\"genbrk\" not found in \$PATH, install the icu development tool \"genbrk"\])
@@ -4669,18 +4670,20 @@ if test -n "$with_system_icu" -o -n "$with_system_libs" && \
if test -z "$SYSTEM_GENCMN"; then
AC_MSG_ERROR([\"gencmn\" not found in \$PATH, install the icu development tool \"gencmn"\])
fi
+
+ AC_PATH_PROG( ICUCONFIG, icu-config)
AC_MSG_CHECKING([ICU version])
- AC_TRY_RUN([
-#include <unicode/uversion.h>
+ ICU_VERSION=`$ICUCONFIG --version`
+ ICU_MAJOR=`$ICUCONFIG --version | cut -d"." -f1`
+ ICU_MINOR=`$ICUCONFIG --version | cut -d"." -f2`
+ ICU_MICRO=`$ICUCONFIG --version | cut -d"." -f3`
+
+ if test "$ICU_MAJOR" -ge "4"; then
+ AC_MSG_RESULT([OK])
+ else
+ AC_MSG_ERROR([not suitable, only >= 4.0 supported currently])
+ fi
-int main(int argc, char **argv) {
- if(U_ICU_VERSION_MAJOR_NUM < 4)
- return 1;
- else
- return 0;
-}
- ], [AC_MSG_RESULT(OK)], [AC_MSG_ERROR([not suitable, only >= 4.0 supported currently])])
- AC_LANG_POP([C++])
else
AC_MSG_RESULT([internal])
SYSTEM_ICU=NO
@@ -4690,6 +4693,9 @@ AC_SUBST(SYSTEM_ICU)
AC_SUBST(SYSTEM_GENBRK)
AC_SUBST(SYSTEM_GENCCODE)
AC_SUBST(SYSTEM_GENCMN)
+AC_SUBST(ICU_MAJOR)
+AC_SUBST(ICU_MINOR)
+AC_SUBST(ICU_MICRO)
dnl ===================================================================
dnl Graphite