summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@suse.cz>2011-05-27 20:39:04 +0200
committerJan Holesovsky <kendy@suse.cz>2011-05-27 20:39:04 +0200
commitca907e02205e8e99e28608ddfe7bdaca24f23aa4 (patch)
treeafdf8fb6a8aef6920ad0f658bdad85c419e0c43e /configure.in
parent817da75b0809642d68b3cab35a1a9348139e9321 (diff)
parent35c884841001c6367d428db8e4407afc4d5077ca (diff)
Merge remote-tracking branch 'origin/integration/dev300_m106'
Conflicts: Makefile.in Repository.mk autogen.sh bin/lo-commit-stat configure.in distro-configs/LibreOfficeOpenBSD.conf distro-configs/LibreOfficeWin32.conf instsetoo_native/util/openoffice.lst ooo.lst.in scp2/source/ooo/module_langpack.ulf set_soenv.in solenv/bin/ooinstall solenv/gbuild/CppunitTest.mk solenv/gbuild/Library.mk solenv/gbuild/LinkTarget.mk solenv/gbuild/TargetLocations.mk solenv/gbuild/platform/macosx.mk solenv/gbuild/platform/solaris.mk solenv/gbuild/platform/unxgcc.mk solenv/gbuild/platform/windows.mk solenv/inc/minor.mk solenv/inc/settings.mk tail_build/prj/makefile.mk
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in354
1 files changed, 318 insertions, 36 deletions
diff --git a/configure.in b/configure.in
index 6ed7ea1fc14e..31f8a4d6a208 100755
--- a/configure.in
+++ b/configure.in
@@ -79,11 +79,6 @@ AC_ARG_ENABLE(ext-presenter-minimizer,
[Enables the Presentation Minimizer extension.]),
,)
-AC_ARG_ENABLE(ext-presenter-ui,
- AS_HELP_STRING([--enable-ext-presenter-ui],
- [Enables extra functionality during slideshows, e.g. selecting pen color.]),
-,)
-
AC_ARG_ENABLE(ext-report-builder,
AS_HELP_STRING([--enable-ext-report-builder],
[Enables the build of the Report Builder extension.]),
@@ -283,6 +278,20 @@ AC_ARG_ENABLE(cairo,
available.]),
,enable_cairo=yes)
+AC_ARG_ENABLE(librsvg,
+[ --enable-librsvg Determines whether to use librsvg library on
+ platforms where librsvg is available.
+ (actually, it is possible to build with
+ --disable-librsvg and to still have SVG support
+ within a running soffice instance, since this
+ dependency is a runtime only dependency.
+ To have SVG suppport at runtime, the librsvg, the cairo
+ and the gobject library - and all depending libraries
+ as well - need to be accessible by the running soffice
+ instance.
+ The intention of defaulting this flag to yes is to
+ indicate this fact to the build maintainer)
+],,enable_librsvg=yes)
AC_ARG_ENABLE(opengl,
AS_HELP_STRING([--disable-opengl],
[Determines whether to build the OpenGL 3D slide transitions component.]),
@@ -1219,6 +1228,20 @@ AC_ARG_WITH(vendor,
],
,)
+AC_ARG_WITH(install-dirname,
+ AS_HELP_STRING([--with-install-dirname],
+ [Specify the directory name of the core LibO install dir. The final
+ installation path is defined by <libdir>/<install-dirname>.
+ The default value is "libreoffice" and the default installation
+ patch is /usr/lib/libreoffice.
+
+ FIXME: It affects only the installation by "make install" and not the
+ generated installation sets.])
+ [
+ Usage: --with-install-dirname=lo-3.4.2
+ ],
+,)
+
AC_ARG_WITH(unix-wrapper,
AS_HELP_STRING([--with-unix-wrapper],
[Redefines the name of the UNIX wrapper that will be used in the desktop
@@ -1386,6 +1409,7 @@ case "$host_os" in
solaris*)
test_gtk=yes
build_gstreamer=yes
+ test_librsvg=yes
test_kde=yes
test_freetype=yes
test_gstreamer=yes
@@ -1418,6 +1442,7 @@ case "$host_os" in
linux-gnu*|k*bsd*-gnu*)
test_gtk=yes
build_gstreamer=yes
+ test_librsvg=yes
test_kde=yes
test_kde4=yes
test_freetype=yes
@@ -1449,6 +1474,7 @@ case "$host_os" in
test_cups=no
test_randr=no
+ test_librsvg=no
test_freetype=no
test_cairo=no
test_fontconfig=no
@@ -1465,6 +1491,7 @@ case "$host_os" in
;;
darwin*) # Mac OS X or iOS
test_gtk=yes
+ test_librsvg=no
test_randr=no
test_freetype=no
test_fontconfig=no
@@ -1484,6 +1511,7 @@ case "$host_os" in
freebsd*)
test_gtk=yes
build_gstreamer=yes
+ test_librsvg=yes
test_kde=yes
test_kde4=yes
test_freetype=yes
@@ -1511,6 +1539,7 @@ case "$host_os" in
*netbsd*)
test_gtk=yes
build_gstreamer=yes
+ test_librsvg=yes
test_kde=no
test_kde4=yes
test_freetype=yes
@@ -2212,6 +2241,7 @@ fi
dnl ===================================================================
dnl Check which Microsoft C/C++ or MinGW compiler is used for WINNT
dnl ===================================================================
+SHOWINCLUDES_PREFIX=
if test "$_os" = "WINNT"; then
if test "$WITH_MINGW" != "yes"; then
AC_MSG_CHECKING([for a friendly Microsoft C/C++ compiler installation path])
@@ -2231,7 +2261,7 @@ if test "$_os" = "WINNT"; then
fi
with_cl_home=`cygpath -d "$with_cl_home"`
with_cl_home=`cygpath -u "$with_cl_home"`
- AC_MSG_RESULT([done])
+ AC_MSG_RESULT([$with_cl_home])
dnl ===========================================================
dnl Check for mspdb80.dll/mspdb100.dll
@@ -2264,7 +2294,7 @@ if test "$_os" = "WINNT"; then
fi
if test -z "$MSPDB_PATH"; then
- AC_MSG_ERROR([You need a mspdb80.dllor mspdb100.dll, make sure it's in the path or use --with-mspdb-path])
+ AC_MSG_ERROR([You need a mspdb80.dllor mspdb100.dll, make sure it is in the path or use --with-mspdb-path])
fi
MSPDB_PATH=`cygpath -d "$MSPDB_PATH"`
MSPDB_PATH=`cygpath -u "$MSPDB_PATH"`
@@ -2272,27 +2302,29 @@ if test "$_os" = "WINNT"; then
PATH="$MSPDB_PATH:$PATH"
AC_MSG_CHECKING([the Microsoft C/C++ Compiler])
- if test "$CL_X64" = ""; then
- if test -x "$with_cl_home/bin/cl.exe"; then
- CC="$with_cl_home/bin/cl.exe"
+ if test -z "$CC"; then
+ if test "$CL_X64" = ""; then
+ if test -x "$with_cl_home/bin/cl.exe"; then
+ CC="$with_cl_home/bin/cl.exe"
+ fi
+ else
+ if test -x "$with_cl_home/bin/amd64/cl.exe"; then
+ CC="$with_cl_home/bin/amd64/cl.exe"
+ fi
fi
- else
- if test -x "$with_cl_home/bin/amd64/cl.exe"; then
- CC="$with_cl_home/bin/amd64/cl.exe"
+ if test -z "$CC"; then
+ AC_PATH_PROG(CC, cl.exe)
fi
- fi
- if test -z "$CC"; then
- AC_PATH_PROG(CC, cl.exe)
- fi
-
- if test -e "$CC"; then
# This gives us a posix path with 8.3 filename restrictions
CC=`cygpath -d "$CC"`
CC=`cygpath -u "$CC"`
+ fi
+
+ if test -n "$CC"; then
# Remove /cl.exe from CC case insensitive
AC_MSG_RESULT([found ($CC)])
if test "$CL_X64" = ""; then
- COMPATH=`echo $CC | $SED 's@\/[[Bb]][[Ii]][[Nn]]\/[[cC]][[lL]]\.[[eE]][[xX]][[eE]]@@'`
+ COMPATH=`echo $CC | $SED -e 's@\/[[Bb]][[Ii]][[Nn]]\/[[cC]][[lL]]\.[[eE]][[xX]][[eE]].*@@' -e 's@^.* @@'`
else
if test -n "$with_cl_home"; then
COMPATH=`echo $with_cl_home`
@@ -2324,6 +2356,19 @@ if test "$_os" = "WINNT"; then
AC_MSG_ERROR([Microsoft C/C++ Compiler not found. Use --with-cl-home or set path to cl.exe.])
fi
+ dnl We need to guess the prefix of the -showIncludes output, it can be
+ dnl localized
+ AC_MSG_CHECKING([the dependency generation prefix (cl.exe -showIncludes)])
+ echo "#include <stdlib.h>" > conftest.c
+ SHOWINCLUDES_PREFIX=`$CC -c -showIncludes conftest.c 2>/dev/null | \
+ grep 'stdlib\.h' | head -n1 | sed 's/ [[[:alpha:]]]:.*//'`
+ rm -f conftest.c conftest.obj
+ if test -z "$SHOWINCLUDES_PREFIX" ; then
+ AC_MSG_ERROR([cannot determine the -showIncludes prefix])
+ else
+ AC_MSG_RESULT(["$SHOWINCLUDES_PREFIX"])
+ fi
+
# Check for 64-bit (cross-)compiler to use to build the 64-bit
# version of the Explorer extension (and maybe other small
# bits, too) needed when installing a 32-bit LibreOffice on a
@@ -2389,6 +2434,7 @@ fi
AC_SUBST(COMEX)
AC_SUBST(MSPDB_PATH)
AC_SUBST(USE_MINGW)
+AC_SUBST(SHOWINCLUDES_PREFIX)
if test "$_os" != "WINNT" -o "$WITH_MINGW" = "yes"; then
@@ -2651,7 +2697,7 @@ dnl ===================================================================
dnl Testing for C++ compiler and version...
dnl ===================================================================
if test "$_os" = "WINNT" -a "$WITH_MINGW" != "yes"; then
- if test -e "$CC"; then
+ if test -n "$CC" -a -z "$CXX"; then
CXX="$CC"
fi
fi
@@ -6173,7 +6219,12 @@ fi
dnl We also need to check for --with-gnu-cp
if test -z "$with_gnu_cp"; then
- AC_PATH_PROGS(GNUCP, gnucp cp)
+ # check the place where the good stuff is hidden on Solaris...
+ if test -x /usr/gnu/bin/cp; then
+ GNUCP=/usr/gnu/bin/cp
+ else
+ AC_PATH_PROGS(GNUCP, gnucp cp)
+ fi
if test -z $GNUCP; then
AC_MSG_ERROR([Neither gnucp nor cp found. Install GNU cp and/or specify --with-gnu-cp=/path/to/it])
fi
@@ -6350,6 +6401,7 @@ if test "$test_gtk" = "yes"; then
if test "$ENABLE_GTK" = "TRUE" ; then
PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.4 gdk-pixbuf-xlib-2.0 >= 2.2 ,,AC_MSG_ERROR([requirements to build the gtk-plugin not met. Use --disable-gtk or install the missing packages]))
+ PKG_CHECK_MODULES(GTHREAD, gthread-2.0,,AC_MSG_ERROR([requirements to build the gtk-plugin not met. Use --disable-gtk or install the missing packages]))
BUILD_TYPE="$BUILD_TYPE GTK"
if test "x$enable_systray" = "xyes"; then
@@ -6385,6 +6437,8 @@ AC_SUBST(ENABLE_DBUS)
AC_SUBST(ENABLE_SYSTRAY_GTK)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
+AC_SUBST(GTHREAD_CFLAGS)
+AC_SUBST(GTHREAD_LIBS)
PKG_CHECK_MODULES( LIBPNG, libpng, ENABLE_QUICKSTART_LIBPNG="TRUE", ENABLE_QUICKSTART_LIBPNG="" )
AC_SUBST(LIBPNG_LIBS)
@@ -6474,6 +6528,29 @@ fi
AC_SUBST(ENABLE_GSTREAMER)
dnl ===================================================================
+dnl Check whether the librsvg libraries are available.
+dnl ===================================================================
+
+ENABLE_LIBRSVG=""
+LIBRSVG_CFLAGS=""
+LIBRSVG_LIBS=""
+
+if test "$test_librsvg" = "yes"; then
+ AC_MSG_CHECKING([whether to use librsvg])
+ if test "x$enable_librsvg" != "xno" ; then
+ PKG_CHECK_MODULES( LIBRSVG, librsvg-2.0 >= 2.14,,AC_MSG_ERROR([requirements to build with librsvg support not met. Use --disable-librsvg or install the missing packages]))
+ ENABLE_LIBRSVG="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ AC_MSG_RESULT([no])
+ fi
+fi
+
+AC_SUBST(ENABLE_LIBRSVG)
+AC_SUBST(LIBRSVG_CFLAGS)
+AC_SUBST(LIBRSVG_LIBS)
+
+dnl ===================================================================
dnl Check whether the OpenGL libraries are available
dnl ===================================================================
@@ -6528,17 +6605,6 @@ fi
AC_SUBST(SYSTEM_MESA_HEADERS)
AC_SUBST(ENABLE_OPENGL)
-# presenter extra ui extension?
-AC_MSG_CHECKING([whether to build extra presenter ui])
-AS_IF([test "x$enable_ext_presenter_ui" = "xyes"], [
- AC_MSG_RESULT([yes])
- ENABLE_PRESENTER_EXTRA_UI=YES
-],[
- AC_MSG_RESULT([no])
- ENABLE_PRESENTER_EXTRA_UI=NO
-])
-AC_SUBST(ENABLE_PRESENTER_EXTRA_UI)
-
# presenter minimizer extension?
AC_MSG_CHECKING([whether to build the Presentation Minimizer extension])
AS_IF([test "x$enable_ext_presenter_minimizer" = "xyes"], [
@@ -7849,6 +7915,205 @@ AC_SUBST(USE_XINERAMA)
AC_SUBST(XINERAMA_LINK)
dnl ===================================================================
+dnl Test whether to build librsvg or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of librsvg])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_LIBRSVG=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_LIBRSVG=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_LIBRSVG=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_LIBRSVG)
+
+dnl ===================================================================
+dnl Test whether to build gdk-pixbuf or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of gdk-pixbuf])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_GDKPIXBUF=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_GDKPIXBUF=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_GDKPIXBUF=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_GDKPIXBUF)
+
+dnl ===================================================================
+dnl Test whether to build glib or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of glib])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_GLIB=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_GLIB=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_GLIB=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_GLIB)
+
+dnl ===================================================================
+dnl Test whether to build gettext or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of gettext])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_GETTEXT=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_GETTEXT=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_GETTEXT=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_GETTEXT)
+
+dnl ===================================================================
+dnl Test whether to build libcroco or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of libcroco])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_LIBCROCO=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_LIBCROCO=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_LIBCROCO=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_LIBCROCO)
+
+dnl ===================================================================
+dnl Test whether to build pango or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of pango])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_PANGO=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_PANGO=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_PANGO=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_PANGO)
+
+dnl ===================================================================
+dnl Test whether to build libgsf or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of libgsf])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_LIBGSF=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_LIBGSF=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_LIBGSF)
+
+dnl ===================================================================
+dnl Test whether to build libpng or rely on the system version
+dnl ===================================================================
+AC_MSG_CHECKING([whether to build own version of libpng])
+
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_LIBPNG=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_LIBPNG=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_LIBPNG=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AC_SUBST(SYSTEM_LIBPNG)
+
+dnl ===================================================================
+dnl Test whether to build libjpeg or rely on the system version
+dnl ===================================================================
+dnl FIXME: this is currently because we have jpeg-6b for our filters
+dnl and jpeg-8 as dependency for librsvg
+dnl this should be unified into using only one version for both
+
+AC_MSG_CHECKING([whether to build own version of libjpeg])
+
+if test "$SYSTEM_JPEG" == "YES"; then
+SYSTEM_LIBJPEG=YES
+else
+case "$_os" in
+ WINNT*) # Windows
+ SYSTEM_LIBJPEG=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ Darwin*)
+ SYSTEM_LIBJPEG=NO
+ AC_MSG_RESULT([yes])
+ ;;
+ *)
+ SYSTEM_LIBJPEG=YES
+ AC_MSG_RESULT([no])
+ ;;
+esac
+fi
+
+if test "$SYSTEM_LIBJPEG" == "YES"; then
+ AC_MSG_RESULT([no])
+else
+ AC_MSG_RESULT([yes])
+fi
+AC_SUBST(SYSTEM_LIBJPEG)
+
+dnl ===================================================================
dnl Check for runtime JVM search path
dnl ===================================================================
if test "$SOLAR_JAVA" != ""; then
@@ -7969,8 +8234,12 @@ if test "$ANT_HOME" != "NO_ANT_HOME"; then
if test -f $ANT_HOME/lib/ant/ant.jar; then
ANT_LIB="$ANT_HOME/lib/ant"
else
- AC_MSG_ERROR([Ant libraries not found!])
- fi
+ if test -f /usr/share/lib/ant/ant.jar; then
+ ANT_LIB=/usr/share/lib/ant
+ else
+ AC_MSG_ERROR([Ant libraries not found!])
+ fi
+ fi
fi
fi
fi
@@ -8052,7 +8321,11 @@ if test "$SOLAR_JAVA" != "" && test "$with_junit" != "no"; then
if test -e /usr/share/java/junit4.jar; then
OOO_JUNIT_JAR=/usr/share/java/junit4.jar
else
- OOO_JUNIT_JAR=/usr/share/java/junit.jar
+ if test -e /usr/share/lib/java/junit.jar; then
+ OOO_JUNIT_JAR=/usr/share/lib/java/junit.jar
+ else
+ OOO_JUNIT_JAR=/usr/share/java/junit.jar
+ fi
fi
else
OOO_JUNIT_JAR=$with_junit
@@ -8107,6 +8380,7 @@ fi
# check that the list is valid
for lang in $WITH_LANG ; do
test "$lang" = "ALL" && continue;
+ test "$lang" = "kid" && continue;
# need to check for the exact string, so add space before and after the list of all languages
all_langs=" $ALL_LANGS "
test `echo "$all_langs" | sed "s|.* $lang .*|found|"` = "found" && continue;
@@ -8164,6 +8438,14 @@ else
fi
AC_SUBST(UNIXWRAPPERNAME)
+INSTALL_DIRNAME=`echo AC_PACKAGE_NAME | tr [[:upper:]] [[:lower:]]`
+AC_MSG_CHECKING([for install dirname])
+if test -n "$with_install_dirname" -a "$with_install_dirname" != "no" -a "$with_install_dirname" != "yes" ; then
+ INSTALL_DIRNAME="$with_install_dirname"
+fi
+AC_MSG_RESULT([$INSTALL_DIRNAME])
+AC_SUBST(INSTALL_DIRNAME)
+
AC_MSG_CHECKING([whether to statically link to Gtk])
if test -n "$enable_static_gtk" && test "$enable_static_gtk" != "no"; then
ENABLE_STATIC_GTK="TRUE"