summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJürgen Schmidt <jsc@apache.org>2011-11-14 12:35:07 +0000
committerJürgen Schmidt <jsc@apache.org>2011-11-14 12:35:07 +0000
commit3360d33d73a80c1c114af3e34ad7867e0388e9be (patch)
tree267a42f5b186e33a99e1ef5f4017cb4edfe52230 /configure.in
parentd931eec926f50f5f4facba1febaf168a3fb300f4 (diff)
118584: remove internal neon and dependencies, build webdav ucp only if system neon is enabled
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 2 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index edb0e9c98b20..947d9d75dbdb 100644
--- a/configure.in
+++ b/configure.in
@@ -526,9 +526,6 @@ AC_ARG_WITH(system-mdds,
AC_ARG_WITH(system-vigra,
[ --with-system-vigra Use vigra already on system
],,)
-AC_ARG_ENABLE(neon,
-[ --disable-neon Disable neon and the compilation of webdav binding
-],,)
AC_ARG_ENABLE(Xaw,
[ --disable-Xaw Disables the use of Xaw for the Netscape/Mozilla
plugin
@@ -1240,13 +1237,11 @@ if test "$enable_copyleft" != "yes"; then
enable_nss_module="no"
enable_gstreamer="no"
with_myspell_dicts="no"
- enable_neon="no"
DISABLE_HUNSPELL="TRUE"
DISABLE_HYPHEN="TRUE"
DISABLE_LIBWPD="TRUE"
DISABLE_SAXON="TRUE"
- DISABLE_NEON="TRUE"
BUILD_EPM="NO"
@@ -1258,7 +1253,6 @@ else
DISABLE_HYPHEN=
DISABLE_LIBWPD=
DISABLE_SAXON=
- DISABLE_NEON=
AC_MSG_RESULT([no])
@@ -1267,7 +1261,6 @@ AC_SUBST(DISABLE_HUNSPELL)
AC_SUBST(DISABLE_HYPHEN)
AC_SUBST(DISABLE_LIBWPD)
AC_SUBST(DISABLE_SAXON)
-AC_SUBST(DISABLE_NEON)
AC_SUBST(BUILD_EPM)
@@ -5020,19 +5013,9 @@ AC_SUBST(XRANDR_LIBS)
AC_SUBST(ENABLE_RANDR)
dnl ===================================================================
-dnl Check for building neon
-dnl ===================================================================
-AC_MSG_CHECKING([whether to use neon])
-if test "$enable_neon" = "no"; then
- AC_MSG_RESULT([no])
- DISABLE_NEON=TRUE
- AC_SUBST(DISABLE_NEON)
-else
- AC_MSG_RESULT([yes])
-dnl ===================================================================
dnl Check for system neon
dnl ===================================================================
-AC_MSG_CHECKING([which neon to use])
+AC_MSG_CHECKING([which neon is used])
if test -n "$with_system_neon" -o -n "$with_system_libs" && \
test "$with_system_neon" != "no"; then
AC_MSG_RESULT([external])
@@ -5040,18 +5023,11 @@ if test -n "$with_system_neon" -o -n "$with_system_libs" && \
NEON_VERSION="`$PKG_CONFIG --modversion neon | $SED 's/\.//g'`"
NEON_CFLAGS="$NEON_CFLAGS -DSYSTEM_NEON -DUSE_DAV_LOCKS=1"
SYSTEM_NEON=YES
-else
- AC_MSG_RESULT([internal])
- SYSTEM_NEON=NO
- NEON_LIBS=-lneon
- NEON_CFLAGS=
- BUILD_TYPE="$BUILD_TYPE NEON"
-fi
+fi
AC_SUBST(SYSTEM_NEON)
AC_SUBST(NEON_VERSION)
AC_SUBST(NEON_LIBS)
AC_SUBST(NEON_CFLAGS)
-fi
dnl ===================================================================
dnl Check for system openssl