summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMichael Stahl <mst@openoffice.org>2011-03-28 10:34:17 +0000
committerMichael Stahl <mst@openoffice.org>2011-03-28 10:34:17 +0000
commit4c2c528a6b6d1475675cc6b3e2154c32d7104016 (patch)
tree6989218c40ee0946e1c0750acf7e69084abacfbb /configure.in
parentf2277b6211713d20bb488415ed1e61e86d81b04a (diff)
solaris11: configure: tweak check for GNU cp so it is found on Solaris 11
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index b9fec5b18f25..4ae734e3fdca 100644
--- a/configure.in
+++ b/configure.in
@@ -5454,7 +5454,12 @@ fi
dnl We also need to check for --with-gnu-cp
if test -z "$with_gnu_cp"; then
- AC_PATH_PROGS(GNUCP, gnucp cp)
+ # check the place where the good stuff is hidden on Solaris...
+ if test -x /usr/gnu/bin/cp; then
+ GNUCP=/usr/gnu/bin/cp
+ else
+ AC_PATH_PROGS(GNUCP, gnucp cp)
+ fi
if test -z $GNUCP; then
AC_MSG_ERROR([Neither gnucp nor cp found. Install GNU cp and/or specify --with-gnu-cp=/path/to/it])
fi