summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThorsten Behrens <tbehrens@novell.com>2011-03-24 08:55:53 +0100
committerThorsten Behrens <tbehrens@novell.com>2011-03-24 08:59:08 +0100
commit710b73a3de05ca8cb6fee069ba23565c78c762d1 (patch)
tree563521d35af02295977be57e719926fa9d2ccdc4 /configure.in
parenta5ca1dcb91d6aa6e4943ac99e402e0ed660a8392 (diff)
Bin explicit checking for extension subdirs
This breaks badly on pristine checkouts (that don't yet have the other repos cloned, and symlinked into the src tree). Should only be a prob for packagers, and they usually know what to do.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in26
1 files changed, 0 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index 82b241fc934d..e28100f725db 100755
--- a/configure.in
+++ b/configure.in
@@ -6285,12 +6285,6 @@ AS_IF([test "x$enable_ext_pdfimport" = "xyes"], [
AC_MSG_RESULT([internal])
SYSTEM_POPPLER=NO
BUILD_TYPE="$BUILD_TYPE XPDF"
- AC_MSG_CHECKING([for internal xpdf module])
- if test -d ./xpdf; then
- AC_MSG_RESULT([OK])
- else
- AC_MSG_ERROR([not existing! (Did you get the -extensions tarball?)])
- fi
fi
],[
AC_MSG_RESULT([no])
@@ -6305,11 +6299,6 @@ AC_SUBST(POPPLER_LIBS)
if test "$ENABLE_PRESENTER_SCREEN" = "YES" -o "$ENABLE_MINIMIZER" = "YES" -o "$ENABLE_PDFIMPORT" = "YES"; then
AC_MSG_CHECKING([for sdext module])
- if test -d ./sdext; then
- AC_MSG_RESULT([OK])
- else
- AC_MSG_ERROR([not existing. get it (did you get the -extensions tarball?)])
- fi
BUILD_TYPE="$BUILD_TYPE SDEXT"
fi
@@ -6317,11 +6306,6 @@ AC_MSG_CHECKING([whether to build the Wiki Publisher extension])
AS_IF([test "x$enable_ext_wiki_publisher" = "xyes"], [
AC_MSG_RESULT([yes])
AC_MSG_CHECKING([for swext module])
- if test -d ./swext; then
- AC_MSG_RESULT([OK])
- else
- AC_MSG_ERROR([not existing. get it (did you get the -extensions tarball?)])
- fi
ENABLE_MEDIAWIKI=YES
BUILD_TYPE="$BUILD_TYPE SWEXT"
if test "x$WITH_JAVA" = "xno"; then
@@ -6358,11 +6342,6 @@ if test -n "$enable_ext_report_builder" -a "$enable_ext_report_builder" != "no"
AC_MSG_RESULT([yes])
ENABLE_REPORTBUILDER=YES
AC_MSG_CHECKING([for reportbuilder module])
- if test -d ./reportbuilder; then
- AC_MSG_RESULT([OK])
- else
- AC_MSG_ERROR([not existing. get it (did you get the -extensions tarball?)])
- fi
AC_MSG_CHECKING([which jfreereport libs to use])
if test "$with_system_jfreereport" = "yes"; then
SYSTEM_JFREEREPORT=YES
@@ -6527,11 +6506,6 @@ if test -n "$enable_ext_report_builder" -a "$enable_ext_report_builder" != "no"
else
AC_MSG_RESULT([internal])
AC_MSG_CHECKING([for jfreereport module])
- if test -d ./jfreereport; then
- AC_MSG_RESULT([OK])
- else
- AC_MSG_ERROR([not existing. get it (did you get the -extensions tarball?)])
- fi
SYSTEM_JFREEREPORT=NO
BUILD_TYPE="$BUILD_TYPE JFREEREPORT"
fi