summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHanno Meyer-Thurow <h.mth@web.de>2011-04-25 21:50:05 +0200
committerHanno Meyer-Thurow <h.mth@web.de>2011-04-25 21:50:05 +0200
commit86dad78a82295277de70a1cd1e2efca65514eabf (patch)
tree227482ce0894fe955e4aa142d91107ae46378303 /configure.in
parentadac311d015e9ac6597cdd8ffbf5984b0e319a43 (diff)
Update '--disable-python' to disable only Python UNO API.
* configure.in:
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in11
1 files changed, 5 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index cf608c91513a..83fb2b3d32d1 100755
--- a/configure.in
+++ b/configure.in
@@ -4091,6 +4091,11 @@ AC_MSG_CHECKING([whether to enable Python 2.x UNO API])
if test "$enable_python" != "no"; then
AC_MSG_RESULT([yes])
BUILD_TYPE="$BUILD_TYPE PYUNO"
+else
+ AC_MSG_RESULT([no])
+ DISABLE_PYTHON=TRUE
+ AC_SUBST(DISABLE_PYTHON)
+fi
AC_MSG_CHECKING([which python to use])
if test "$_os" = "WINNT"; then
@@ -4143,12 +4148,6 @@ AC_SUBST(PYTHON_CFLAGS)
AC_SUBST(PYTHON_LIBS)
HOME=`echo $HOME | $SED 's:\\\\:/:g'`
AC_SUBST(HOME)
-dnl disable python
-else
- AC_MSG_RESULT([no])
- DISABLE_PYTHON=TRUE
- AC_SUBST(DISABLE_PYTHON)
-fi
dnl ===================================================================
dnl Check for system translate-toolkit